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OpenRoads Design – Geometry 

P-4-1: Horizontal Geometry 

Return to Index 

Training 

SIG - Fundamentals of Horizontal Design https://event.on24.com/wcc/r/2186799/CA4FC23886823D081C512BF456AC8A41  

OpenRoads Designer Help Let's Begin with OpenRoads Designer (bentley.com)  

Short Version Geometry (bentley.com) 

Open the 12345-Geometry.dgn, Default model, attach references and modify the View as needed.  May need to save settings and 
reopen the dgn if the terrain’s Default-3D model is not displaying in the Default window. 

Set Feature Definition from the Feature definition toggle bar and set to use active. 

Use the OpenRoads Modeling Workflow Geometry tab Horizontal tools.  Place individual lines and arcs for element design and 
then complex them together or use the Complex Geometry by PI to place a linked Alignment. 

To display the Alignment curve data, ticks, and stations, use the Annotate element tool from the OpenRoads Modeling > Plan 
Production tab 

P-4-2: Vertical Geometry 

After the Horizontal Geometry is designed create the Vertical Geometry.  First ensure that you have an active terrain model.  Use 
the view control tools to open multiple views.  Select the horizontal geometry and use the context sensitive menu to open a Profile 
view.  If the view does not contain the existing ground select the terrain and set it active. 

Use the OpenRoads Modeling Workflow Geometry tab Vertical tools.  Place individual lines and arcs for element design and 
then complex them together or use the Complex Geometry by PI to place a linked Alignment.  The existing ground can be set as 
the active profile if desired to just use the existing elevations.  This is not recommended for design. 

 

https://event.on24.com/wcc/r/2186799/CA4FC23886823D081C512BF456AC8A41
https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20Help-v18/en/GUID-B3D9FE45-8E50-49DB-BB0E-CC9FA557871B.html
https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20Help-v18/en/GUID-3822DB1F-3630-46FD-8D54-4091CF5D5819.html
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P-4-3:  Geometry from SS4 OpenRoads 

Return to Index 

Before You Begin 

This process is assuming you have OpenRoads SS4 Horizontal and Vertical geometry alignments that need to be brought forward 
into ORD to use in design. 

Create LandXML files of the SS4 Alignments 

Start InRoads, opening your project’s Geometry.dgn file to the Default model.  Use Element Selector and select the alignment.  In 
Element Information update/define the feature name.  With the alignment still highlighted hover on it to get the popup menu and 
select Open Profile Model and click in a view to contain the profile. 

In the Profile view select the profile.  In Element Information update/define the profile name and set it active if not already.  Only 
the active profile will transfer with the horizontal in the xml file. 
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Set the Default view active again and select the horizontal 
alignment, hover, and select the Horizontal Geometry Report 
icon.  Alternately go to the Analysis and Reporting tasks and 
select Horizontal Geometry Report and then select the alignment.  

When the report appears, select the 
AlignmentsToLandXMXL.xsl style sheet report at the top of the 
list.  Use File > Save As to save the file as Type Text File (*.txt) 
but when naming the file add .xml to the end.  Browse to the 
folder (in your CONNECT project directory) you want to save it in 
and click Save. 

 

Repeat these steps for Each alignment. 
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Open ORD and Import the LandXML Alignment Files 

Start ORD and select your ORD Project and the Geometry.dgn’s Default model.  

Set the Workflow to OpenRoads > Geometry tab and select the General tool Import 
Geometry.  Select the .xml file that you saved in the previous exercise and click Open. 

Check the LandXML box and select the Import button.  This will import the horizontal 
and vertical geometry into the dgn. 

Update the Feature Definition 

Use Element Selector to select the imported geometry and update the Feature Definition 
to Alignment Mainline (or other appropriate feature).  The geometry will update to the 
correct symbology but the stations will not be shown. 

To display the Stations and Curve data you must use the Element Annotation tool from 
the Drawing Production tab.  With the element selected click on the tool and data point 
on the screen to accept.  The stations, ticks, pc/pt’s, bearings and curve data will all be 
added to the drawing. 

Set the Existing Terrain as active prior to opening the profile. 

The active profile should already exist but its feature definition is not defined.  Go to the Geometry tab, and select Open Profile 
Model from the Vertical section or select the Alignment hover and select it from the popup menu.  An easy way to bring up a profile 
if you only have the default model in view 1 is to use the Right Click hold menu > View Control > Views plan/profile.  Next select 
the horizontal alignment and then the view for it to go in. 

Use Element Selector to select the profile and change its feature definition to match it’s horizontal feature definition.  Set it active 
if not already. 

Your alignment is good to go! 

Repeat for each alignment. 
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OpenRoads Designer - Corridors 

P-5-1: Creating Corridors 

Return to Index 

Before You Begin 

OpenRoads Designer works using the Civil Tools to perform all the roadway design steps.  A corridor is the main civil object used 
for modeling a roadway.  The corridor civil object acts as a container for all the elements and design constraints that make up your 
design. 

Note that references to "12345" in file names refer to the project's five digit Project Number.  

Use the Create Template tool to check to see if an active template file is set.  If no templates are displayed in the box use the file 
open command to open one or go to section P-5-2: Templates to see how to copy one to the correct location and rename it so it 
can be found. 

Review the engineering base plan, engineering report, as well as the pavement recommendation prior to creating the corridor.  It 
is a good idea to create the Typical Section before creating a corridor to ensure the design follows intent. Review the intended 
template before use and edit to match the standard widths, slopes, and depths indicated in these resources.  The no component 
template can be used first to work on the corridor design prior to switching to a template containing all the components when the 
pavement recommendation comes in. 

Corridor training can be found in How to Deliver - From Survey to Plan Production - Session 3 https://www.bentley.com/en/Global-
Events/Accelerator-Series/2019/OpenRoads-Virtual  

 

Short Version 

1. Open the Drawing, reference attach the Terrain and Geometry drawings.  Set the Terrain active. 
2. Use the OpenRoads Modeling workflow > Corridors tab Create > New Corridor tool, select the alignment, answer and accept 

through the prompts.  (Ensure you are hitting on the 2D alignment geometry feature.) 
3. Select the Template to be applied and set the start and ending stations. Reset to complete. 

https://www.bentley.com/en/Global-Events/Accelerator-Series/2019/OpenRoads-Virtual
https://www.bentley.com/en/Global-Events/Accelerator-Series/2019/OpenRoads-Virtual
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Create the Corridor 

Each Corridor should be in its own DGN for larger projects.  For smaller projects a single DGN can be used with multiple corridors.  
If DGN files have not yet been created, see the Create Project Drawings.  

Open 12345-P-Corridor.dgn.  Open the Default model and attach the Combined.dgn's Default model with Live Nesting = 1, if not 
already attached. 

Using Level Display, expand the dgn's Default-3D entry.  Expand the Combined DGN's Default-3D's attachments. Shut off the 
display of all referenced Default-3D models in any attached reference except the Terrain's. 

Select the terrain element and use the context popup menu to set the terrain as active. (may need to make the Default-3D model 
snapable)  

 

Use Element Selector with the Individual and New toggles active. Select the Alignment that you want to create a corridor with.  
Hover on the alignment and the Context Menu popup will appear. (Element Selector needs to be set to Individual and New buttons 
active).   

Select Create Corridor or go to the OpenRoads Modeling Workflow Corridors Tab Create - 
New Corridor tool and hit on the alignment.  

 
 

  

https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/Drawing-Names.aspx
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Reset to use the active profile of the alignment chosen or choose another from the drop-
down as needed.  Set the https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-
Home/SitePages/OpenRoads-Corridor-Design-Stages.aspx in the tool box then type a 
Name for the corridor into the on screen tooltip and left click to accept.  

 
   

 

After the corridor is created the Create Template Drop toolbox becomes active.  
The first prompt is for the template (name).  Use the Alt key + down arrow to 
bring up the Pick Template box.  Select the Template and hit OK.  Left click on 
the screen to accept the template, then define the start and end points. You can 
type in the Start and End stations of the Proposed profile or use the alt key to 
set the Start and End stations to the beginning and end of the alignment.  Set 
the template Drop Interval = 5, and set the Transitions to 0.  Templates are only 
placed\created where the selected profile exists. 

After the template drop is placed you can create additional template drops with 
different stations by selecting another template and following the prompts 
again.  Reset to finish placing templates.  After each drop is defined the template is applied to the stations indicated and added to 
the corridor. 

Your corridor has now been created and can be refined using the other corridor creation tools.  Many tools work by hitting on the 
feature’s 2D lines that were created.  Shut off the display of all the 3D design components by opening the level display, expand 
the tree under your Default-3D model, highlight only the Default-3D model, then right click in the levels pane and select All Off. 

https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/OpenRoads-Corridor-Design-Stages.aspx
https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/OpenRoads-Corridor-Design-Stages.aspx
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Save Settings and Save.  Review your Design by viewing Dynamic Sections.   

NOTE: 

If you cancel out of the command before selecting a template an empty corridor outline could still be created... Delete it before 
creating a new one. 

Use Project Explorer - Civil Model Tab to review all the corridors in a DGN. 

For projects with Bridges create separate corridors with overlaps for clipping the approach, the bridge, and the departure. Video 

https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/Displaying-Dynamic-Cross-Sections.aspx
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/bridge-corridor-clip.avi?csf=1&web=1&e=m4oUXS
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Design Stage 

The corridor design stage and the template drop increment determine the frequency of the placed 
templates.  NHDOT has determined that the Final Template drop increment should be 5’ therefore 
the template drop increment should be 5.  When working on a conceptual 5, design 2 or final 
design 1, the design stage uses a template drop multiplier to determine the actual increment of 
drops translating to 25’, 10’ and 5’ respectively.  To see additional information about the design 
stages properties, use the Home tab’s Primary tool Explorer.  Expand the OpenRoads Standards 
tab of the Explorer, expand Feature Definitions > Corridor > and select and review the settings of 
the different design stages in the properties box. Also refer to the Help.  
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P-5-2: Templates 

Return to Index 

Before you Begin 

Templates are used to create corridors.  Each template is basically a typical section that contains the features and components 
that are extruded along an ORD alignment.   

Since each project is unique and will likely need modification to any standard template, a “seed” template file has been created 
— ApprovedCE-NHDOT-Templates.itl — which contains templates developed by the NHDOT.  When working in a new project, 
this file should be copied into the project’s …\Cadd\Standards\Template Library\ directory and rename it with your project 
number (such as 12345CE-NHDOT-Templates.itl) for it to be found by OpenRoads. 

If your template file is not found when you open the Create Template panel check the project number in the CFG file name and 
make sure it matches the 12345 in the itl\cfg file name. 

Templates are continuously being updated as new ones are created and old ones revised, it will become necessary to update 
your ITL file or even replace it.  Notice will be posted when significant changes take place.  For additional information on 
Templates the ORD Help can be viewed as well a search on Connect Advisor for Templates.  They can be accessed from File > 
Help.   

New Design Manual templates have been created and are prefaced with DM_ rather than the previous DM-.  these templates 
should be used as they have updated components allowing for widened and steeper ditches to be developed without the 
components looping.  

https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20CONNECT-v9/en/GUID-E30B815B-E3CD-484B-BDF7-8C06A44801A2.html
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Create Template - Tool  

The Create Template tool is used to create and modify 
templates.  It can be accessed from the OpenRoads 
Modeling workflow > Corridors tab > Create tools - 
Template.  The main templates are designated with DM 
(Design Manual) prefix and match what is shown in the 
Design Manual typical sections.  A curbed template TC-
12-4-Curb also exists.  The naming convention helps to 
indicate the intent of the template.  Prefixes -  TC = 
Corridor Templates, TL = Linear Templates, TS = 
Surface Templates. 

Components to create templates are in the Template 
Components folder. Creation of Templates is covered in 
the Help files as well as on the Bentley learn server and 
may be documented here in the future.  

Common practice should be to create a new 12345 folder in your template file and copy\rename any templates you want to use in 
your project into the new folder.  You can then edit the templates without corrupting the original. 
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Copy Templates from other ITL files  

The template library organizer is used to copy templates from one ITL file to 
another.  Delete any similarly named folder prior to opening the Organizer.  It 
is not an especially user friendly interface. 

1. Select OpenRoads Modeling workflow > Corridors tab > Create tools - 
Template to open the Create Template panel. 

2. Tools > Template Library Organizer.. opens the current ITL file into the 
organizer panel. 

3. Click on the folder to expand the ITL’s contents.  To the right of the 
second pane select the ... to pick the ITL to copy from. 

4. If copying a folder of templates, drag it from the right pane up to the top 
ITL name of the left pane to copy it. 

5. Individual templates can be copied by dragging and dropping also but 
must be dropped onto a folder. 

6. Close the Organizer to save the changes. 

Preliminary Design “No Components” Templates 

Latest design practice would be to use the DM-12-4-no-components to start 
your design.  The Horizontal and vertical alignments, lane and shoulder widening’s, superelevations, slope break modifications for 
guardrail would all take place using this stripped down template file.  This greatly improves processing speeds as well as just the 
speed of opening a dgn.  Once the majority of the top line design is complete, a set of cross sections would then be cut and used 
to review the side slopes and write parametric constraints that set the side slopes, slope transitions and rounding’s throughout the 
whole project.  The template would then be changed to the DM-12-4 template that has material components.  All parametric 
constraints are the same for the two templates so the top line design would reflect what was designed using the no-components 
template.  The select materials issues/conflicts would then be looked at and resolved. 

The reasons for this approach are because the DM templates do not contain fill height criteria with multiple end conditions, this 
reduces the complexity of dealing with multiple components and multiple end condition conflicts.   
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DM-0-12-4-NC-Color with Color Coded Slopes   

A new DM-0-12-4-NC-Color template file has colored cut and fill height components that show what the slopes are and help 
visualize where the Parametric Constraint slope transitions need to be.  When ready to work on the slope transitions, the Corridor’s 
template can be changed from the DM-12-4-no-components to the DM-0-12-4-NC-Color template.  To clearly see the slope, 
change the Default’s View attributes to Illustration.  Fill slope colors are 6:1 Green 55, 4:1 Yellow 84: 2:1 Red 80, cut slope colors 
are 4:1 light green 102, 3:1 Fuchsia 191, 2:1 Orange 7.  Transition slopes are hot pink 252. 

 

 

Using this we can clearly see where the slope transitions need to occur. Changing the corridor Feature Definition from Concept 5x 
w/ Meshes to Final w/ Meshes which uses a template from modifier of 1 vs the 5 may help, though the pink transition slopes don’t 
seem to display in some instances. 

Create Parametric Constraints to control the slope transitions over 50-foot intervals.  Steeper slopes and some of the yellow slopes 
may change as the actual end condition is forced to a steeper slope.   
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Template Parts 

Templates are made up of points and components.  A point’s constraint value can be controlled and modified through Parametric 
Constraints which are defined as the label.  These labels are variables which can be used with the Create Parametric Constraint 
tool in the Corridor to modify their values. 

Components are made up of the points which define them and have other properties such as Display Rules and Parent 
Components.  The Component’s Display rules allow components to be turned on and off based on criteria controlled by PCs.  If a 
Parent component is turned off, then all of its children will also turn off. Other display rules work automatically to display the 
appropriate cut or fill select material and can be very tricky to define. 
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End Conditions 

End Conditions are Components that seek an intersection with the active terrain.  They have properties similar to display rules in 
that end conditions are displayed if certain conditions are met within defined parameters.  i.e. a 6:1 slope end condition will 
typically have height of fill criteria defined for it.  Meaning it will solve and display if it finds an intersection point within 6 vertical 
feet of the slope break.  Cut slope end conditions are checked before fill slope conditions and are controlled through the end 
condition’s priorities.  The SFill SubEC X end condition is priority 1 for many templates but its width is set to 0 so it will not solve 
unless its width is widened through a parametric constraint.  Setting the LT_Fill_Sub_EC_width allows the end condition to look 
for an intersection with the existing ground along the subgrade from the EP out.  This results in a variable slope from the Slope 
Break but can be helpful if you are trying not to chase slope work. 
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P-5-3: Parametric Constraints – Control the Design 

Return to Index 

The Create Parametric Constraint and the Corridor Objects tools are found on the OpenRoads Modeling Workflow in the 
Corridors Tab under the Edit tools.  Use either tool to create a Constraint.  

 

Parametric Constraints or PC's have been defined to control almost every aspect of the NHDOT Templates.  Material depths, 
travel way, shoulder, cut and fill, 
widths and slopes as well as 
guardrail display and offset.  These 
constraints are used to refine/define 
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your design.  You will use the constraints to transition your slopes from 6:1 - 4:1 - 2:1 as well as transition the rounding’s from 5 
feet to 0 feet when going from a 4:1 fill to a 6:1 fill.  Slope transitions should generally occur over 50 feet.  

Some constraints like the LT & RT_EL_width can be set to 0, others which are used to extend and 
break slopes in superelevated areas like the LT and RT_Shldr_Break_width points should be set to 
a minimum offset of 0.005 so that the points slope property is still usable to create subsequent points. 

When editing or creating multiple constraints using the Corridor Objects tool it is sometimes beneficial 

to use the Unlock - Activate Rule button  .  This allows you to create and edit constraints without 
each change or addition being processed.  Reactivate the lock when done adding constraints, Close 
the tool then reprocess the corridor to have all the changes processed. 

Import\Export Parametric Constraints 

Constraints can be exported to a text file which can be edited and re-imported to create the 
constraints as shown here by copying the RT_Shldr_width constraints and editing them for the 
LT_Shldr_width. 

 

 

Display Switches 

Some constraints control the display of template components like a switch through display rules.  The default value for RT_GR is 
-0.5, which has the Guardrail hidden.  When the parametric constraint for RT_GR is set to positive (+) it turns on the display of the 
guardrail.  LT_GR needs to be set to negative to turn it's display on. 
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When rounding’s, represented by a tick mark offset from the toe (LT & RT_Tick_width) are set to a negative number their display 
is shut off. 

The display of the shoulders and slopes for many templates can be controlled with the LT and RT_Shoulder_Display PC, when 
XT_Shldr_Display is set to an offset other than 0 they are hidden. 

If the Depth_Base is set to 0 it shuts off its display so it will not be shown in the corridors quantities. 

Modify all values of a Parametric Constraint in a Template 

Mass editing of the material depths (or any constraint) can be achieved by opening the 
Active Template tab, expand the Parametric Constraints entry and double click on the 
desired depth.  This will bring up a box showing the default value which can be 
changed.  i.e. if the Depth_CRGR is set to -0.66666 or 8" it can be set to -1, (tab to fill 
the value in the box) then OK to change all points in the template to the new value.  
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P-5-4: Superelevation 

Return to Index 

Before you Begin 

Create or open a 13245-SuperElevation.dgn and reference in the Geometry drawings.  It is sometimes helpful to also reference 
the Corridor.dgn files as well to see the limits of the design.  

Superelevations can be created using the Superelevation tools on the Corridors tab of the OpenRoads Modeling workflow.  Supers 
can be imported as parametric constraints generated from the Excel worksheet that was used in SS4 or as point control lines from 
the same Excel sheet.   

ORD Superelevation  

Open the Default model and adjust the display as necessary to be able to select the 2D 
geometry feature of the roadway. 

Open the OpenRoads Modeling workflow > Corridors Tab > Superelevation tool Create 
Superelevation Sections.  Supply a name and set the Minimum Tangent Length to a large 
number.  Set the Feature Definition and accept through the prompts to create the Super 
Section. 

After creating the Super Section the next tool should automatically start…. Define the 
superelevation lanes by defining the name (use the templates TW’s point name P_TW_L or R), 
side, width, and normal crown slope for both the left and right lanes accepting through after 
verifying each entry. 

After Create Superelevation Lanes the next tool should automatically start… the Calculate 
Superelevation tool allows you to define the AASHTO Rules file, the e max rate, the Length 
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calculation type, design speed and the pivot method. 
When this tool is completed with the Open Editor box 
checked the Superelevation Editor will be displayed.  

Use the AASHTO_2018_NH.xml when working on 
NHDOT projects.  The delivered xml files have not been 
corrected for AASHTO’s Errata which corrected some 
entries in the tables.  The Relative Gradient’s calculations 
have also been changed to match how NH calculates it in 
the Highway Design Spread Sheet previously used. 
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Superelevation Editor 

For information on how to use the Superelevation editor see the Help, Learn server or connect advisor.  The Editor allows you to 
view and modify the calculated Superelevation by editing the Black text in the Station and Cross Slope columns.

  

When you have finished modifying the Superelevation you 
can create and save the reports.  The next step is to assign 
the superelevation to a corridor.  Save dgn and open the 
corridor dgn.  With the Default model active, reference attach 
the Superelevation dgn’s Default model.  Use the Assign to 
Corridor tool to apply the Superelevation to the corridor by 
first selecting the super section and then the corridor to apply 
it to.  
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Corridor Modeling – By Constraints – non-preferred method in ORD 

Using Template Constraints for Superelevation - Video 

Found under Corridor Modeling Tasks the Corridor Objects - Parametric Constraints tools allow for importing of txt files containing 
constraints. 

An Excel spread sheet has been created for Super Elevation design and is located in ss4_superelevations_2_4.xlsm.  It should be 
copied into each project prior to use.  The sheet will create parametric constraints to import into the corridor for superelevation 
transitions.  Fill in all appropriate boxes for each curve, then open the Parametric Constraints worksheet tab.  

Click the "Add Output All" or "Add Output Shoulders Only" to define which entries are to be exported.  Click the "Export to TXT" 
button to create the file in the project directory. 

*** This information should be checked carefully for errors such as overlapping curve transitions *** 

*** YOU ARE RESPONSIBLE FOR YOUR DESIGN *** 

***The latest sheet is good for 18 curves - if you need more use a second sheet and increment the files by adding - Part 1  Part 
2... to the ROAD NAME*** 

 

Open the Corridor Objects panel by selecting the tool on the Corridor Modeling task menu. Then select Parametric Constraints on 
the left side of that panel. 

The Import Parametric Constraint tool from the Corridor Objects - Parametric Constraint view is used to import the text file of the 
correct format.  Constraints can also be exported from a corridor, edited with a text editor and re-imported. 

Super elevation control lines can be created using the appropriate tabs, but it is recommended to take advantage of using the 
Parametric Constraint tab of the spread sheet in that it also creates the constraints for the shoulder roll over and is more easily 
reviewed together.  

When editing or creating multiple constraints using the Corridor Objects tool, it is sometimes beneficial to use the Unlock - Activate 
Rule button.  This allows you to create and edit constraints without each change or addition being processed.  Reactivate the lock 
when done adding constraints. Close the tool then reprocess the corridor to have all the changes processed. 
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P-5-5: Parametric Constraints – Control the Slope Transitions 

Return to Index 

The Create Parametric Constraint and the Corridor Objects tool are found on the Corridor Modeling task menu. Use either 
tool to create a Slope Constraint.  Constraints for slopes include L(R)_Fill_slope and L(R)_Cut_slope.  These constraints will 
override the default slopes from the fill height criteria used in the no-comp(onents) templates as well as those in the 2 slope 
templates such as the DM-12-4 and DM-12-10. 

Create Slope Parametric Constraints 

The design should be worked through in order... basically the same order that the Corridor Design documentation is in.  Constraints 
to transition your slopes from 2:1 - 4:1 - 6:1 as well as transitioning the roundings from 5 feet to 0 feet when going from a 4:1 fill to 
a 6:1 fill should be next after the Guardrail Design.  The Video shows the process of using the results of a no component template 
that uses the Typical section's fill height criteria to determine the base slope solutions.  These slopes are shown and annotated on 
a set of cross sections and then hand recorded into an https://nhgov.sharepoint.com/:x:/r/sites/DOT-ProjectCentral-
Home/CADD%20Document%20Library/report-slopes-
ticks.xlsx?d=wba11871a8661417b944804d91080c8e9&csf=1&web=1&e=ELAhVs. The spread sheet helps to determine where 
the parametric slope constraints are needed to set the slopes and transitions between different slopes.  Slope transitions should 
generally occur over 50 feet.  The section of the spread sheet to the right can be used to help write the parametric constraints 
(copy into text file) but it may be easier to just have the recorded slopes displayed while you add the constraints by hand into the 
Corridor Objects > Parametric Constraints section. - Video 

When editing or creating multiple constraints using the Corridor Objects tool it is sometimes beneficial to use the Unlock - Activate 

Rule button .  This allows you to create and edit constraints without each change or addition being processed.  Reactivate the 
lock when done adding constraints, Close the tool then reprocess the corridor to have all the changes processed. - Video 

Create Slope Rounding (Tick Width) Parametric Constraints 

Slope roundings are not shown on the cross sections as there is no real way to transition their lengths or reliably match them into 
the existing slopes.  Slope roundings are represented by a tick mark on the cross section at the appropriate distance from the 
slope intersection point.  Parametric constraints need to be created to set the tick marks at the correct distance from the toe of 
slope.  Each Template has default slopes and a default Tick width.  These can be reviewed and modified by hand (adding individual 
constraints) using the Excel spread sheet created in the previous section.  An alternate method is to create and edit a report of the 

https://nhgov.sharepoint.com/:x:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/report-slopes-ticks.xlsx?d=wba11871a8661417b944804d91080c8e9&csf=1&web=1&e=ELAhVs
https://nhgov.sharepoint.com/:x:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/report-slopes-ticks.xlsx?d=wba11871a8661417b944804d91080c8e9&csf=1&web=1&e=ELAhVs
https://nhgov.sharepoint.com/:x:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/report-slopes-ticks.xlsx?d=wba11871a8661417b944804d91080c8e9&csf=1&web=1&e=ELAhVs
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/slope-constraints.avi?csf=1&web=1&e=hUjpbZ
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/process-slope-pc.avi?csf=1&web=1&e=UKFuIa


 
 

NHDOT CAD/D Connect Documentation 

ORD Design Documentation Page 26 of 93 Last edited:  February 15, 2024 

cut and fill slope parametric constraints.  The report is edited to have the Tick width replace the slope for all variations of the cut 
and fill slopes parametric constraints then the constraint name is updated to reflect the Tick width constraint. - Video 

 

When roundings (LT & RT_Tick_width) are set to a negative number they are shut off in newer templates.  This allows you to have 
slopes shown without the cut or fill linestyle being placed such as at intersections were proposed side road slopes match into the 
mainline slopes.  

Review Displaying Dynamic Cross Sections 

  

https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/tickwidths.avi?csf=1&web=1&e=YKZYr3
https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/Displaying-Dynamic-Cross-Sections.aspx
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P-5-6: GuardRail Platforms 

Return to Index 

Before you Begin 

Create or open a 12345-P-GuardRail-Platforms.dgn and reference in the Combined, and the corridor dgns that require guardrail.   

Guardrail platforms can be created within the corridor or created separately by creating a corridor for each in their own dgn.  By 
creating a separate corridor for each platform, the quantities for the platform can be excluded from the corridor as the specifications 
indicate.  The GuardRail Platform’s offsets and slopes are created from imported parametric constraints generated from an Excel 
worksheet.  Constraints to turn on the GR display and widen the slope break to 2.5’ between the platforms are also generated in 
the Excel file and need to be imported into the corridor dgn. 

GuardRail Note and Calc Sheet 

The guardrail_field_notes-calc_sheets-openroads_constraints.xlsx is used to design guardrail and to create the parametric 
constraints for the platform widening, grading and 
turning on the display of the guardrail.  There are 3 tabs 
in the file, GR Field Review Sheet, the GR Worksheet 
and the OpenRoads Constraints sheet.  Design 
information from the GR Worksheet is used in the 
OpenRoads Constraints sheet by populating the drop 
down selections in green and entering the stationing in 
fuchsia. 

There are 3 sections of constraints generated for each GR run.  Each 
section should be highlighted, copied and pasted into notepad, PFE or 
Notepad++ and saved as text files.  The middle 2 lines are for the actual 
roadway corridor and the Approach and Departure sections for the GR 
Platform corridor(s).  Name the test files appropriately with GR-# 
followed by the approximate station values found above each section 

https://www.dot.nh.gov/sites/g/files/ehbemt811/files/inline-documents/guardrail_field_-notes-calc_sheets-openroads_constraints.xlsx
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and then LT or RT.  i.e. GR-1-App-10618-10712-RT.txt, and GR-1-Cor-10712-11237-RT.txt, and GR-1-Dep-11237-11332-RT.txt.  
Alternately, have both the approach and departure sections in the same .txt file. 

Create Guardrail Corridors 

With the 12345-P-Guardrail-Platforms.dgn open, and referenced corridor attached, select the Mainline Geometry, hover and 
select Create Corridor from the Pop-up list.  Make sure you are selecting the 2D geometry reference.  If needed, shut off the display 
of the 3D corridor and geometry reference models.  Right click to use active profile and name the corridor with the corresponding 
GR-# that you are working on.  Use the Alt+Down arrow to select the template, Templates Corridor\TC-RT_GR-Platform, Left 
click to accept.  Next, key in the start and end stations of the platform shown in the Excel file above the constraint section.  Use a 
5-foot template drop.  When finished placing the template drop you can place another one for the departure platform using the 
start and end stations above that section.  Right Click to end. 

Create Point Controls and import Constraints 

The Template that was used has points corresponding to the points on the roadway corridor.  Select the corridor, hover and select 
Corridor Creation Tools > Corridor Objects from the Pop-up Menu.  Select Point Controls from the Corridor Objects tool box, and 
select Create Point Control.  Three point controls need to be created.  They should be created from the Start of the Geometry to 
the End so they will already be defined when/if you add additional template drops.  

 Description 

1 Description-EP/ Both /Linear Geometry/Corridor EP_R /Plan Element/ hit on the Roadway corridor’s P_EP_R feature. 

2 Description-SB/ Both /Linear Geometry/Corridor Slope Break_R /Plan Element/ hit on the Roadway Corridor’s P_SLP_B_R. 

3 Description-Toe/ Both /Linear Geometry/Corridor Toe /Plan Element/ hit on the Roadway Corridor’s toe P_TOE_R. 

This should align the platform corridor on to the roadway corridor.  In the Dynamic section view the platform should appear as a 
thin fill over the roadway slopes.   

Widen the platform and turn on the 2D and 3D guardrail by importing the txt files created earlier.  In the Corridor Objects Box switch 
to the Parametric Constraints section.  Click on the Import Parametric Constraints tool and import the App and Dep files created 
earlier. 

If the 2D guardrail line is not showing up, use OpenRoads Modeling workflow > Model Detailing tab > 3D tools pane > Plan By 3D 
Element from the dropdown menu and click on the 3D guardrail. 
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Open the Roadway Corridor and Import the Parametric Constraints 

The corridor .txt file can be imported directly into the roadway corridor’s constraint section.  Open the P-Corridor.dgn and Select 
the corridor, hover and select Corridor Creation Tools > Corridor Objects from the Pop-up Menu.   In the Corridor Objects Box 
switch to the Parametric Constraints section.  Click on the Import Parametric Constraints tool and import the Cor file created earlier. 

If the 2D guardrail line is not showing up, use OpenRoads Modeling workflow > Model Detailing tab > 3D tools pane > Plan By 3D 
Element from the dropdown menu and click on the 3D guardrail. 
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P-5-7: Drives and Side Roads 

Return to Index 

Introduction 

Drives and Side Road civil cells have been developed for the designer’s use.  Standard driveways should always match into the 
edge of pavement of the main corridor.  Side roads can also match into the edge of pavement or into the travel way so the shoulder 
is continuous from the main road into the side road.  Alignments for either should generally be designed perpendicular from the 
mainline out to at least the EP before skewing or curving. 

Side Roads and driveways are designed after the Mainline corridor has been completed.  The horizontal and vertical geometries 
will match into the Mainline.  All alignments that are intended to be stationed and shown on the plans should be created in the 
project's Geometry.dgn.  All other Drive alignments, Civil cells and corridors can be created in the P-Drive.dgn and side roads can 
either be in the mainline corridor or in their own corridor.dgn file if the work is extensive. 

 

Create the Drive Alignment 

Open or create the xxxxx-P-Drives.dgn file, Default model and attach the existing reference files, geometry and the corridors the 
drives will match into.   
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P-5-8: Importing Corridors from SS4 InRoads 

Create Corridor Object Reports 

Using InRoads, open each SS4 corridor dgn in the old –ss4 project.  Now that 
the project has been renamed you may need to update the Project Defaults to 
point to the correct file locations.  Open Project Explorer to the Civil Model Tab.  
Expand the dgn dropdown > Expand the Corridors entry.  Each corridor listed 
should be examined and determined whether it needs to be exported.  Right click 
on the corridor and use Zoom To to find it (may or may not work).    

Select the corridor and make note of the Horizontal Name and Profile Name that 
the corridor was created from as they need to be recreated using Section P-4-2: 
Geometry from SS4..  Next, right click on the corridor expanding the Corridor 
Creation Tools and select Corridor Objects.  The box will appear containing the 
parts of the corridor.   

 

 

 

 

 

 

 

 

Click on each category in the left pane and if information is present, Right Click in the gray area and select Export.  
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Create a Folder(s) in the Connect project 
OpenRoads\Data\SS4-Corridors\RoadName\ and 
save each export there with corresponding name and 
description for each corridor.  The Parametric 
Constraints are really the only part of the corridor that 
can be imported into the ORD corridor but the rest of 
the Exported files provide information on what was and 
needs to be done. 

 

 

 

Template Reports 

With both InRoads and ORD open, review each template and, if necessary, make modifications to standard ORD templates 
mimicking any changes that were done to the SS4 templates used in the corridor.  SS4 templates can be imported into ORD but 
there are more changes that would need to be done than its worth.  When editing ORD templates, check for any new functionality 
(like shoulder shutoff display rules) that work to make things easier before just making modifications (like deleting the shoulder 
and creating additional template drops). 

Parametric Constraint Reports 

Edit the exported ParametricConstraint.csv file and remove any super elevation slope constraints as supers are done with the 
Superelevation tools in Connect and the shoulder Rollovers are controlled in the template.  Dimension Height constraints can also 
be deleted as they are not used in ORD.   

Most PC’s are named the same as those defined in SS4 but some have been upgraded.  Review the constraints and use 
Find/Replace to update any constraint names to those used in the ORD template selected.  Import this edited file into your ORD 
corridor. 
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Point Control Reports 

These cannot be imported.  Use the report to see what other control lines may need to be recreated in ORD, whether other 
alignments or other corridors possibly in different corridor dgn files.  The list will help you determine those dependencies but cannot 
be created until those pieces are created.  Superelevation Point Controls will be created when the SuperElevation tool Assign to 
Corridor is used. 

External Reference and Clipping Reference Reports 

Neither of these categories can be imported as they will need to point to things newly created in ORD.  They will help you to 
understand what may need to be created and referenced in order to recreate the SS4 corridor design in ORD. 

 

Continue creating the reports until all corridors are completed or determined to be unnecessary. 

 

Follow the steps in  OpenRoads Designer - Corridors for importing the Parametric Constraints file after creating the template drops.   

The SS4 Corridor dgn file’s Default-3D model can be attached to an ORD Corridor’s Default-3D model in order to compare the 3D 
Models by viewing the Dynamic Sections.  The regular way of attaching the Default to the Default model and the 3D being 
automatically attached will not work as connect does not recognize the SS4 files as being civil files. 
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OpenRoads Designer - Creating Cut Sheets 

P-6-1: Creating Cross Section Sheets – Named Boundaries 

Return to Index 

Before you begin – Creating ORD Cross Section Cut Sheets - Video 

Additional tasks:  P-6-1A – E, create existing features, e-row, env, create corridors, p-row, p-utilities, p-drainage, xs detail, End 
Area Volumes.   

Attach Reference Files – Display Information to be Sectioned 

Open ORD to the NHDOT Workspace and the project’s WorkSet.  Open/create the 12345-XSections.dgn. 

With the Default model active, Reference file attach the Combined.dgn with live nesting set to 1.  Next, attach all other dgn files 
that you want to section over.  E-Terrain or E-MX-Survey-Terrain, E-MX-Survey-Linear, E-Drainage, E-ENV, E-ROW-Lines, E-
Terrain-Rock, E-Utility, Geometry, P-Cor, P-Drainage, P-Utilities, P-Drives, Earthwork, P-Guardrail-Platforms, P-ROW all with live 
nesting set to 0.  As you accept through each drawings attachment make sure you see the message that the Default-3D models 
are automatically being attached.  Do not include point feature drawings such as the E-MX-Survey-Points as those features are 
represented in the XS Detail drawings. 

View both the Default and Default-3D models by Right Clicking and holding to get the popup menu and select View Control > 
Views Plan/3D.  Set the Default-3D view active by clicking on the top of the view.  The content of the cross sections is determined 
by what is displayed in this View/Model.  Shut off Communication Nodes, Electrical Nodes, Gas and Water nodes.  Update the 
view, Save Settings and Save the dgn.  This will be the Cross Section seed file. 

Copy the XS Seed and Attach the appropriate XS Detail 

Copy/Rename the seed to 12345-XSect-RoadName.dgn.  Add the RoadName.  With the Default view active, attach the appropriate 
12345-XS-Detail-RoadName.dgn.  Save Settings and Save the file, repeat for each road as needed.  

https://engage.bentley.com/newhampshire-dot-resources/training/new-hampshire-cross-section-cutsheets
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Create named Boundaries 

The cross sections are generated through Named Boundaries.  The cross 
section boundaries are 3D elements.  Ensure you have 2 views open, a view 
of the Default (2D model) and the Default-3D model.  With View 1 active, use 
the OpenRoads Modeling Workflow’s Drawing Production tab and select the 
Place Named Boundary tool.  Select the cross section image in the top of the 
tool.  Set the drawing seed from the dropdown, this 
should fill in many of the properties in the tool box.  If a 
previous Group of sections were created, you can add 
to the group by selecting it from the group dropdown.  
Otherwise, you are being prompted to Identify a Path 
Element to create boundaries along.  The Name will 
take on the name of the Feature that you select.  The 
offsets, interval, clearance(s), can be changed but are 
set for NHDOT standards.   

Check the Create Drawing and Show Dialog boxes then 
accept through the on cursor prompts to create the 
Named Boundaries.  The Boundaries will be placed in 
both 2D and 3D views and the create drawing box will 
display. 

Create the Drawings 

The Create Drawing box is filled in per NHDOT 
standard setup.  Decide whether to have the drawings 
added to the sheet index or not and hit OK to create the 
Cross Section drawing and sheet model!  The progress 
bar in the lower right will display your progress.  Be 
Patient.  The last Cross Section sheet will be displayed 
when finished.  
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Review and add Additional Annotation 

In the previous step the NH XS Preferences Annotation Group was used to annotate the drawings, and much was annotated.  
From existing features to the ROW and ENV feature to the proposed offset and elevations of the roadway features and the cross 
slopes.  Additional annotation groups label the NH XS Detail features, NH XS Barrier as well as XS EAV Anno for Earthwork 
material if that information has been generated. 

Re-Annotating Sections After Changes 

When changes are made to Corridors and other dgns that are referenced to the cross sections or other reference files attached 
their 3D models will be updated when the sections are opened.  The annotation will not be. 

Using the OpenRoads Modeling Workflow > Drawing Production tab > Annotations pane select the Model Annotation dropdown 
and select Remove Model Annotation.  Check the box for all drawing models and accept.  This will remove all annotation from the 
sections.  You will have to then re-annotate the sections using each Annotation Group.  Start with the NH XS Preferences, then 
NH XS Detail, NH XS Barrier if any is present and finally the XS EAV Anno if that has been done.  Alternately a group called NH 
All can be used that will annotate all the features, but it takes quite a bit of time to run.  The annotate NH All does not include the 
EAV box. 

After you select a group and accept the command, a box showing the Annotate Progress Form will appear.  Move your cursor into 
the box to keep it on top so you can see the progress.  If it gets hidden and you start the next command, it may crash or not finish 
annotating the sections. 

Editing Annotation Groups - Changing Top Frame Annotations 

The cross sections are set up to annotate a list of features contained in the annotation groups.  To edit the list, make the Default 
View active.  Open the Explorer’s OpenRoads Standards Tab, Expand Standards and then select the drawing name.  Right click 
on it, then select Update Standards From dgnlib.  This will update the Annotation Group entries to the latest definitions.   

Next open the Annotation group used to modify the point annotation list.  Expand the > Drawing Name > Annotation Groups > 
Cross Sections > Drawing > NH XS Preferences (or NH All).  Right Click and select Manage.   Alternately select the annotation 
group and in the Properties pane select the Annotation List and click on the … button.  This will bring up the annotation Group for 
editing.  The entry for XS Top Frame controls the list of points that are annotated with offset and elevation across the top of the 
section.  Select XS Top Frame.  This will display Row list and Row Properties which shows the Location list of points to be 
annotated.  Click on the Add filter button above the Expression to alter the list. 
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Highlight an entry and then click on Remove to remove it from the list or Scroll to the Bottom of the list and click in the blank box 
to add a new entry.  The old list was an exclusion list meaning it Added all points on the Top line and the entries told it what not to 
annotate.  This new list is an inclusion list meaning whatever is in the list will be annotated.  Entries should use the OR setting.  As 
a minimum the Road Trav Way, Shldr Edge of Pave, Slope Ditch Front and Toe features should be labeled.  All others can be 
removed.  When done, click Apply Expression Changes to save the list then the X to close the box.  After editing the Offset Row 
the Z or elevation list should be edited to match the same point list entries. 

The Annotation Group Entries are used in more than one group.  If you update the NH All group point list the NH XS Preferences 
will be updated also as it has the same entries for the XS Top Frame. 
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Editing Annotation Groups – Changing Slope Annotation Segments 

As above, to edit the annotation group in Explorer, Expand the > Drawing Name 
> Annotation Groups > Cross Sections > Drawing > NH XS Preferences (or NH 
All).  Right Click and select Manage.  There are 2 entries for Slope annotation, 
XS Left (& Right) Slope Annotation.  Select one of them and then click in the 
Location box and then the … button that appears.  The 3 expressions control the 
selection of points confining them to top line points on the left or right side of the 
CL.  These should not need to be modified.  At the top is a dropdown set to > 
Create list of Segments, the list of segments is at the bottom of the box and can 
be changed by clicking on the box to the right Select Segments from Template.   

At the top of the Select Segments box - use the dropdown 
to select a template.  This will fill in the list of available 
points.  Entries in the bottom left can be selected and then 
using the arrow will copy them to the list of segments.  
Alternately the Point 1 and Point 2 can be selected from 
the dropdown lists and the green + will add the segment 
to the list.  

Different Templates can be used to seed the point list so 
the segment list can be created for a variety of Templates.  

 

 

 

Close the Select Segments box when done and then Apply Expression Changes and close the filter to save it. 

 

Remember to open a section Drawing model, Remove the model annotation and then Reannotate all the sections to see the 
changes you made to the Group.  
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End Area Volumes 

Cut and fill volumes are created in the Cross Section dgn.  Workflow OpenRoads Modeling 
> Home tab Model Analysis and Reporting pane >  select Civil Analysis dropdown Create 
Cut and Fill Volumes.  Next Use the Create End Area Volumes report tool from the 
dropdown.  The Volumes report can be saved for quantity calculations.  The EAV boxes are 
added by selecting Model Annotation from the Drawing production tab and selecting the 
XS EAV Anno C-F group.  A different group, XS EAV Anno C-F-R-M can be used if Muck 
and or Rock is present on the sections.  Check the All Drawing Models box.  

Entries for Rock or Muck removal can be found in the Volumes Report.  They are not 
automatically filled into the annotation box and must be edited by hand. 
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P-6-1A: Create Features of ENV and ROW Elements 

Return to Index 

Before you begin 

This process can take place once you have an existing terrain model as well as delineated wetlands or existing row lines drawn.  
The intent of this process is to featurize and assign elevations to elements that need to be labeled on the cross sections. 

 

Attach Reference Files 

Open/Create the drawing to be worked on, the 12345-E-ENV, E-ROW-Lines or P-ROW. 

View both the Default and Default-3D models by Right Clicking and holding to get the popup menu and select View Control > 
Views Plan/3D.  Set the Default view active by clicking on the top of the view.  Reference file attach the Combined.dgn with Live 
Nesting set to 1.  Fit View. 

Next Reference File Attach the drawing containing the MicroStation elements to be featurized.  Live nesting should be set to 0 
when attaching the env, erl, or prw files from the Prj directory.  In Level Display, turn off all levels in the reference file.  Next Turn 
on only levels that need to be annotated on the Cross sections.  In the Reference file Dialog box select the reference file.  Use 
Tools > Merge into Master and then click in the view to copy all the elements displayed into the dgn and automatically detach the 
dgn file. 

Save Settings and Save the dgn.  Use File > Open to re-open the dgn.  This will make some of the 3D elements from the attached 
reference files visible in the Default view that were previously not displayed. 

  



 
 

NHDOT CAD/D Connect Documentation 

ORD Design Documentation Page 41 of 93 Last edited:  February 15, 2024 

Create Features from Elements 

1. Use element selector and select all elements in the drawing by clicking on Select All.  
Expand the extended settings by clicking on the triangle at the right if not already 
expanded, use the level tab to display levels with elements in them.  Next unselect all but 
one level.  Start with isolating the top level first and progress through each in turn.  

2. In the Feature Definition toggle bar Set 
the use active feature button on the left 
and select the linear feature definition 
for the elements selected.  Use the 
Create Civil Rule Feature tool from 
OpenRoads Modeling workflow, 
Geometry tab’s, General Tools, Design 
Elements, drop down menu.  

3. Data point in 
the view to 
create the 
features.  

 

 

 

4. With the features still selected use the Profile From Surface tool in the Vertical group of 
the Geometry tools to attach elevations to the new features.  Data point on the screen to 
Profile the selected elements, next Select the Existing terrain model by clicking on it. 
(do not right click to use active terrain model as this can cause problems when the features 
are imported and no terrain is active).  Accept through the rest of the prompts as displayed 
to the right to attach elevations to the features.  

Repeat steps 1 – 4 on each level containing elements.   
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P-6-1B: XS Detail Tick Features for Section Annotation 

Cross section detail tick features are created from point features that are deemed relevant to appear on the 
cross sections.  They include trees, poles, hydrants and such.  A point feature station offset elevation report 
is run on the 12345-E-MX-Survey-Topo.dgn’s point features as well as an alignment xyz report to get the 
information for a macro which draws tick mark elements at the 50 foot stations.  These tick marks are 
featurized and profiled over the terrain model to assign elevations.  A separate dgn should be created for 
each Alignment for the tick features to be included in the XS drawing for that Alignment. 

Note: in newer project the E-Detail.dgn contains cells, not point features – use the Survey-Topo.dgn for the 
report. 

DGN setup 

Open the 12345-XS-Detail.dgn's Default model.  Check that the Combined.dgn is attached with live nesting 
1 to see the project’s existing detail drawings.  Reference File Attach the 12345-Geometry.dgn file (no 
nesting) as well as the ….\OpenRoads\Survey\12345-E-MX-Survey-Topo.dgn that contains the point features.  Save settings, 
Save the dgn and reopen it.  Set the existing terrain model Active. 

Using only the Default model view, shut off all reference files that don’t have point features, except the 12345-Geometry.dgn's 
Default Model. Also shut off the Default-3D model reference.  The view should now only show the Geometry and the E-MX-Survey-
Topo Default models. Save Settings and Save the dgn.  This file will be the Seed detail file.  Continue by Copying/Save As this file 
as 12345-XS-Detail-RoadName.dgn 

Create Alignment Report 

If a 50' interval alignment report in .XLS format already exists, skip this section and continue to create the detail station & offset 
report.  Select the Horizontal Geometry Report button that is found on either the Analysis & Reporting or the Horizontal Geometry 
Task menus. 

Follow the Heads-Up prompt and select the alignment (in the Default View) associated with the cross sections you wish to annotate.  
Click the Right Mouse (Reset) button to complete the selection process. 

Confirm that the boxes on the Horizontal Geometry Reports panel for Lock to Start, Lock to End and Interval are all checked.  Set 
the Interval value to 50. 
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If your alignment does not start at an even 50 value, uncheck the Lock to Start box and enter a 
start station that is at an even 50 foot value. 

The last prompt looks for Profile information.  This report does not need to have vertical 
information, so any response for this prompt will suffice.  If there is interest in other reports 
beyond the scope of this procedure, then specify Active Profile so that the vertical component 
is included. 

OpenRoads will open the Bentley Civil Report Browser and display the default horizontal report.  
This browser offers many predefined report options on the left side of the panel.  The right side 
of this panel displays the output of the selected report option.  From the left side of the report 
window, select the HorizontalAlignmentIntervalXYZ.xsl report. 

The report must have the correct station format before saving.  Tools > Format options > 
Stations should be set to SS+SS.SS   Direction should be ddd^mm^ss.  When the report is 
displayed, select Save As... from the File menu and select the Microsoft Excel option.  Provide 
a File name.   

Create Station/Offset Detail Report 

Use Element selector and drag a box around all the point features to be reported in the project area selecting them.   Note that 
only features which typically appear on cross sections will be processed.  

Once the point features are selected, choose the Point Feature Station Offset Elevation Report tool from the OpenRoads Modeling 
Workflow - Model Analysis & Reporting tab - Reports Dropdown. You will be prompted to click on the alignment (select it in the 
Default view) and then data point to accept the selected detail features. When the default report appears, change the report to 
StationOffsetNorthingEastingElevationFeature.xsl. Use the Save As option on the File menu of the report window to save this 
report as an Excel (*.xlsx) file.  Open the report to check its contents. 

Create Cross-Section Detail Features 

Once the reports are created, the next step is to create a series of lines at the even 50' station which is nearest to each detail 
feature. If not already, Open the 12345-XS-Detail-roadname.dgn, Default model that was created to contain these detail 
lines.  Creating separate drawings for each alignment's detail ticks (by using the File > Save As command). 
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To create cross section detail features in OpenRoads Designer, set the workflow to Drawing 
> Utilities tab > Macros pane select XSDetail macro from the drop down menu then click Play. 
Select the detail and alignment xlsx files created in the previous steps. Click Apply if you plan 
to do another alignment after or OK if this will be the only one processed.  The macro creates 
short line segments offset at each 50-foot station.   

 

1. Use Element Selector to select everything in the drawing.  Switch to the Element 
Templates tab of the element selector.  Click (or click and drag) on each to deselect 
all templates except one, leaving only it selected.  

2. Next use the Feature Definition Toggle bar drop down list, expand Linear > XS Detail 
> and set the feature to match the selection and turn on the Use Active Feature toggle 
button. 

3. Use the Create Civil Rule Feature tool from the Geometry tab’s General Tools pane 
> Design Elements dropdown list to set the feature definition and Accept.  The 
selected lines should now be features of the type that is active. 
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4. The features are in the Default model.  In order for them to show up on the cross 
sections, they will need elevations.  Use the Geometry tab’s Vertical pane’s Profile 
Creation dropdown tool Profile from Surface to attach elevations to the features.  Make 
sure the feature definition is still defined and the elements still selected from the 
previous step.  Accept through the prompts and Right click to use the active Terrain 
model when asked.   

 

The names of the features can be 
annotated on the cross sections.  
Attach the 12345etxt.dgn for tree 
sizes and descriptions.  The Point 
Feature Station Offset Elevation 
Report created earlier will provide 
the + station of the features. 

Use Element Selector to select 
each tick and edit the name in 
Element Information to include the 
+ station value for all features.  Pole 
numbers, tree sizes and 
descriptions are not required on the 
sections. 
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P-6-1C: Cross Section Earthwork Features 

Creating Cross Section Earthwork Features 

Cross Section Earthwork features include Topsoil, Pavement Removal, Unsuitable Materials as well as Limited Reuse Soils which 
are delimited with a 2D outline that is used to create clipped terrain models.  The depths will be created with surface templates. 
Muck and Rock will also fall into this category but are dealt with somewhat differently. 

 

This information will be stored in the 12345-Earthwork.dgn. Note that references to "12345" in file names refer to the project's five-
digit Project Number. 

 

Create Earthwork Feature Boundaries 

First, the area to be computed needs to be delineated as a closed 2D shape.  Set the level to the feature you are going to delineate. 
The level names are Strata - followed by the type. 

Use the Fill Area Boundary created previously and any other elements to create closed areas/shapes for the features needed.  For 
example, use Element Selector and select the Fill boundary, drive edges and the existing edge of pavement. 

Use the Create Region tool to delineate Topsoil removal areas. Set the fill type to Flood (the left most icon at the top of the panel) 
and check the box to Keep Original. 

To define areas of pavement to be removed, a color plan or the hearing plan can be attached as a reference. The Fill area boundary 
and the edge of pavement features can be used to determine the area of pavement to be removed. 

After all the shapes are defined, use the Terrain Modeling task Create Clipped Terrain Model to create a separate clipped terrain 
model for each area.  Use the NH_Prop_Earthwork Feature Definition under the Terrain Display features and set the Feature 
Name to reflect the area and location as shown below. 
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Apply Surface Template 

A Surface Template needs to be applied to each clipped terrain to define the material and depth.  See the chart below.  If a different 
depth of material is needed Open the template editor, Copy the desired template, rename it and re-specify the depths below the 
origin. 

Topsoil removal depth and any unsuitable material should be defined in the geotechnical report.  Existing pavement depths may 
be found in the pavement recommendation or from the borings or straight-line diagrams. Areas of differing depths should be 
defined separately and a different depth template assigned.  Drives usually only have 2 or 3 inches of pavement vs. the roadway 
possibly having 5 or more. 

 

Earthwork Summary Sheet Description 

Terrain Name * 

Template Name 

2A Bituminous Pavement in Fill Sections Earth - Pavement x" Exist Pave 

8 Topsoil Removed Beneath Fill Sections Earth - Topsoil x" Topsoil 

9 Unsuitable Material Removed Beneath Fill Sections Earth - Unsuitable x" Unsuitable 

Limited Reuse Soils LRS Earth - LRS Unsuitable 18" LRS Unsuitable 

* A description can be added to clarify areas.  For example, 

Earth - Pavement - LT Sta 21+00 - 22+25 
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P-6-1D: Rock Excavation Quantities 

Introduction 

A set of 25’ sections is created and sent to Materials & Research for Rock line interpolation.  Sheets are returned to design and 
scanned.  Lines are drawn in plan view at each section location and the profile displayed.  The scanned files are referenced into 
each Profile View of the section location traced and set active.  Create a terrain model from all sections.  Then apply a surface 
template. 

Create Sections for Materials & Research 

Create Rock Terrain 

Create/Apply Earthwork Surface Template 

After the Rock terrain model has been created, review the Dynamic sections to determine the greatest depth of rock removal.  
Create a new Surface template with the components vertical depth that is greater than the largest rock removal depth.  Set the 
Feature definition to Mesh\XS Components\Strata – Rock.  This Feature definition should have the Volume Option set to Substrata. 

In the Earthwork.dgn file’s Default model reference in the Rock Terrain.dgn.  
Open the Default-3D model.  

OpenRoads Modeling workflow > Model Detailing Tab > Create Closed Mesh 
tool to create a mesh for rock calculations to be done on. 

In the XSections.dgn file attach the Earthwork dgn file as well as the Rock 
Terrain.dgn file.  The Civil analysis tool Compute cut and fill volumes is used.  
When it finishes, use the Create End Area Volume Report.  The report will show 
the total Rock which can be ignored…. As well as the Strata-Rock (Removed) 
which is what you want to annotate onto the sections EAV table cell. 

  

https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/Create-Rock-Surface-from-Sections.aspx
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P-6-1E: Skewed Drive Sections (and Profiles) 

Introduction 

Creating skewed drive sections is a process that includes creating horizontal and vertical geometry, adding extra named 
boundaries to create sections as well as displaying and referencing the skewed drive profiles into those sections.  The process 
can be done by adding the additional sections into the main group or by creating a new group of just the drives. 

Open the Drives.dgn’s Default model and reference the Combined.dgn with live nesting 1, the Geometry and Corridor dgns with 
no nesting.  Adjust Level Display so that no Default-3D Levels or Models are displayed other than the Terrain’s.   

Create the Drive’s Horizontal Geometry 

Skewed Drives should be created by elements with a tangent perpendicular from the Mainline alignment out to the P_EP and then 
skewing along the drive. 

Use the OpenRoads Modeling Workflow Geometry Tab Horizontal > Geometry Pane > Place Line Between Points command.  
Use Feature Definition Alignment Elements.  Select 2 points along the CL of the drive in the skewed area.  Use the Trim to Element 
command to extend this line back to the Corridor’s EP.  Place Line Between Points and set the snap mode to Perpendicular.  
Select the Mainline alignment and slide the tangent back and forth ensuring it’s perpendicular and then snap to the skewed line’s 
endpoint on the EP. 

In the feature definition Toggle bar set Alignment Drive and use the Create Complex tool to join the pieces and create the connected 
drive geometry.  If the drive is in a cut section a reference line (Feature = Construction Control) 7’ over at the slope of the shoulder 
from the EP can be created using the Single Offset partial command and then the Profile by Slope from Element.  Rename the 
created drive feature adding the approximate station and side for identification purposes. 

Create the Drive’s Vertical Geometry 

Right Click in the default view and hold until the pop-up menu displays.  Move into the View Control menu and select Views Plan/ 
Profile/3D.  OK.  When asked, hit on the Drive alignment in the Default view then the bottom view to display the profile in it.  In 
View Attributes the view’s Exaggeration can be modified from the Default 10 to 1 so the profile looks more like a section for easier 
viewing.  

In the Profile View, Select Create 3D Cut. Full and click in the profile view to display the cut of the 3D model. Snaps will be turned 
off in the referenced Cut graphics.  In Level Display Select and right click on the referenced Drive’s Default-3D model and turn 



 
 

NHDOT CAD/D Connect Documentation 

ORD Design Documentation Page 50 of 93 Last edited:  February 15, 2024 

Snaps on by checking it.  From the Profile Creation menu select the Profile Intersection Point command.  Select the Drive and 
then the Edge of Pavement element and a point should appear on the profile at the location of the feature showing the location of 
the drive’s intersection elevation point. 

Set the Feature Definition to Elements Alignment again and create the drive profile from elements starting with Lines.  The drive 
profile should start at the EP of the corridor using a Origin Point snap on the intersection point.  Back in the profile view select the 
Line command again and you should be able to snap to Corridor’s EP.  If the drive is in a cut, define the second point using an 
Origin Snap selecting the Construction Control cell that was placed or set the length and slope to the next point.  Adjacent Drive 
Slopes should not exceed a 10% algebraic difference in grades of lengths not less than 10’ generally.  Place the next line from the 
previous one with a Key Point snap at its end and set the length and slope of the next tangent.  Use the Right arrow key to switch 
between them and lock the entries by hitting the Enter key.  Continue until the profile matches in, the last tangent section can be 
Trimmed to Element to meet the existing ground.  Change the Feature Definition to Alignment Drive and use Complex Geometry 
by Elements to link the pieces together.  Select the connected profile and set it active.  The drive should now be displayed in the 
3D view.  
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Create Drive Profile Drawing for Xsection Reference 

Review the cross section that was cut at the Drive location 
and determine the height of the section as well as the Top 
Clearance used. 

With the drive’s profile view active, use OpenRoads 
Modeling workflow > tab Drawing Production, then Select 
the Place Named Boundary tool.   

• Drawing seed (none), Detail Scale 1”=10’ 

• the profile should be named for its mainline station 
value and side.   

• Start station set to 0. 

• Stop location set to 1+00 for 10 scale sections set 
vertical. 

• Vertical Exaggeration to 1 

• Top Clearance to match the sections (typically 14). 

• Available Profile Height can be limited to 40’.   

Accept through the prompts to create the named 
boundary and bring up the create drawing box. 

Fill in the Create Drawing box as shown.  Click OK when 
done to create the drawing. 

Save Settings and Save. 

Open the Drawing model just created and shut off all the 
levels in the active model leaving the levels from the 
reference file turned on.  Plot a skewed drive cell. 
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Place a Drive Civil Cell and Manipulate It 

After placing the drive civil cell, click on Create 3D Cut to display the driveways select materials in the profile view. 

Create a Station Offset Report from the Mainline Alignment to each Drive 

Set the workflow to OpenRoads Modeling > Home tab > Model Analysis pane, select Reports > Station Offset Report.  Select the 
roadway alignment and then click on each driveway alignment Reset to complete and have the report show up.  Save this report.  
Each drive’s profile can also be reported on and saved. 

Open Cross Sections drawing model and reference in the Drive Profile 

Open the Cross Section dgn file and then open the drawing model associated to the drive section.  Reference file Attach the drive 
profile with live nesting 99.  Proposed and existing levels can be turned off for the actual section which may not follow the drives 
skew.  This information can be clipped out of the sections drawing models reference file.  Also shut off the drives profile elevations.  

 

  

P-6-1F: Controlling Displayed information on the Cross Sections 

Introduction 

The various reference files contain the base information that is displayed on the sections and the cross section annotation groups 
control what is annotated on the sections.  Other information from reference files is used to generate the End Area Volumes and 
the Volumes report for quantities but is not needed to be displayed on the finished cross section plots for the contractor.  It may 
be beneficial to Create a Saved View of the display status so it can be used when annotation needs to be updated as well as one 
to globally shut the levels back off. 

Global Display 

Global display is used to turn off levels that you don’t want displayed on the cross sections.  Simply turning off the display of levels 
in the Default-3D model is not sufficient to turn them off in the actual sections.  The Global Display of levels can be achieved thru 
the Level Manager or thru the Level Display tools.   
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Construction Plan Check List – for Cross Sections  

Review the Construction Plan check list for a list of what should be displayed on the sections.  Right click on the screen to open 
the View Control menu and select 2 Views Plan/3D.  This will display both Default and Default-3D models.  Make the Default-3D 
active.  Using the Level Display change the Type from View Display to Global Display.  Next shut off levels that don’t need to be 
displayed. 

Corridor and drive dgn files can have their base courses shut off so only the Top and Bottom meshes are displayed.  The 
EarthWork.dgn can have all of its levels shut off.  All survey point features can be turned off.  In the XSections.dgn all of the 
Volumes- levels can be turned off. 

 

When done updating the levels state, save Settings and then Save the dgn.  Create a Saved View for future use to recall the 
Global display settings if the annotation was redone and levels were turned back on.  To ensure that the changes make it to all the 
sheets it is suggested that the dgn is closed and reopened before printing. 
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P-6-2: Plan Cut Sheets 

Return to Index 

Introduction – Creating ORD Plan Cut Sheets Video 

Working with ORD to create the cut sheets is a bit different than only using MicroStation as in the past.  In ORD, reference files 
are attached both as 2D and 3D drawings.  Knowing the content of each drawing will help to ensure that the correct information is 
being shown on the plans produced.  For many drawings 2D information will be shown on the plan sheet.  Cells representing the 
symbology of Utility and Drainage features need to be referenced from their 2D models.  Corridor and Drive dgns should have their 
3D models displayed as the 3D model is the only model information that gets clipped out of the design when placing civil cells 
along the corridor or at Bridge locations. 

The Cut Sheet Seed dgn will be set up and copied to create subsequent cut sheet sets.  The default model of a cut sheet dgn is 
used to turn levels and reference files on and off in each sheet set, very similar to the Master dgn’s view definition in SS4.   

**** Note that for plan and profile cut sheets, the Sheet model has the Drawing model attached with Display Overrides set to Never 
and the Drawing model has the Default model attached with Display Overrides set to Never!  This means that if you want to turn 
a level or reference file on or off you need to open the Default model, modify the view and save setting and save the dgn to save 
the Reference and Level state.  You may have to reopen the dgn to see the changes propagated through to the sheet models!   

Create Cut Sheet Seed dgn - Attach Reference Files 

Create new drawing 12345-Cut-Sheet-Seed.dgn either in the CutSheet folder of the prj directory or create a new \CutSheet folder 
in the OpenRoads folder.  Use the ORD seed file - …\NHDOT\Standards\Seed\NH_SeedORD_Design.dgn  

With the new drawing open and its Default model active, attach the project’s reference files.  Use Reference File Attach and attach 
the Combined.dgn with live nesting set to 1.  If using a Proposed Container file, also attach that with live nesting set to 1.  All other 
proposed files such as the Corridor, Drainage, Drive, and Utility files should be attached with live nesting set to 0.  MicroStation’s 
files can be attach using the Drawing workflow > Utilities tab select the NHREF Macro > PLAY.  The nhref macro may attach some 
of the civil drawings like the Geometry drawings so review the attachments carefully. 

The Open Ref Lev macro can be used to turn levels and reference file display off / on for a particular plan set.  It will only work if 
the Reference file’s logical names were defined during the attachment process.  The Default-3D model attachment’s logical name 
will not be defined and must be assigned by hand.  See the Drawing name list for Logical names of Civil drawings. 

https://engage.bentley.com/newhampshire-dot-resources/training/new-hampshire-ord-plan-cutsheets
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Use Level Display to turn levels on and off for the plan set.  Remember to look at both the Default 2D model’s levels as well as the 
Default-3D attached model levels.  Can turn some levels Off that you know will be off in any cut sheet such as the Corridor outlines, 
Template Drop outlines. The Right click menu can be accessed and Off by element used to shut off displayed levels. 

Save Settings and save the dgn. 

Create Named Boundaries 

Named Boundaries are the clipping elements for the cutsheets.  The 
Place Named Boundary tool is used to create the named boundaries of 
the various types of plans, from plan, profiles to cross sections and 
details. 

Set the workflow to OpenRoads Modeling > Drawing Production > 
Named Boundary tool 

Select the Drawing seed in the top and then select the Alignment in the 
Default model View 1.  Ensure the correct geometry and name is 
selected by viewing the popup information on your cursor.  Set the start 
station of the first cut sheet and then move to the location of the end of 
project and select the stop location. 
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Create the Drawings (from checking the Box)  

Sheets of equal length will be created.  Sheets can be placed one at a time of 
varying lengths.  Select any sheet Boundary and you can move vertices to 
change the shape of the clipped area.  With the Create Drawing box checked, 
the cut sheet Drawing models and the Sheet models will be created.  It is 
suggested that you actually uncheck the Create Drawing box and verify that 
the sheets are where you want them.  Modify the Named Boundaries then use 
the Named Boundaries Tool Box to create the drawings.   

Accept through the prompts. 

The Create Drawing box is as shown.  Use the default Annotation Group (Plan 
Annotation). Change the Logical name to the plan type you are creating.  i.e. 
DRN PLAN 1, or GEN PLAN 1.  Click OK 

 

This image shows the Drawing 
Model’s properties.  Note the 
Display Overrides are set to 
Never, and the model is 
synchronized to Plan 1 Saved 
view. 
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This is the Sheet Model’s Reference Attachment settings of the Drawing 
Model.  Note that the Display Overrides are set to Never. 

 

After reviewing the Drawing and Sheet models return to the Default model 
in View 1, Save Settings and Save the DGN. 

To create the first set of cut sheets use the File > Save As command and 
choose the folder and drawing name.  12345-Gen-Plans. 

The Drawing will open.  Note that if you view the Default model you will see 
that the view’s level state is the same as the sheet model’s. 

 

 

 

 

Create Drawings from the Named Boundaries Toolbox 

Below and to the right of the Named Boundary tool click on the down arrow.  
This will open the Named Boundaries box. After creating all the boundaries 
and modifying them the drawings can be created by selecting the plan group 
name and clicking on Create Plan Drawing.  if the Show Create drawing 
dialog toggle is set the create drawing box will appear. Click Ok to create 
the drawing and sheet models.  
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Open the Default model view.  Use Level Display to shut off any levels not appropriate to the Plan Type.  Corridor dgns should 
display their 3D levels so that any clipped areas will not display, DU dgns should display their 2D model’s levels as that is where 
the 2D annotation cells are.  The Guardrail levels are an exception.  The corridor’s Default model should have the Guardrail turned 
on and have it turned off in the Default-3D model. 

When the Default view setup is finished Save Settings, Save the DGN.  Reopen the dgn and all sheet models should be synched 
with the drawing models which is synched to the Default model.  When changes to the level state or additional reference files need 
to be attached do it in the Default model, Save settings, save the dgn and reopen the file to see the changes propagated through 
to the sheet models.    
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If the sheets become out of synch with the Default model (should not need to be done!) 

Go to the OpenRoads Modeling workflow, then Saved views.  With the Default model displayed in view 1 select the first Saved 
View, Plan 1 and use the Update Saved View Settings tool and click in the view.  Repeat for each defined Saved View.  Save 
Settings, Save the DGN then CLOSE it. 

 

Reopen the DGN and open a Sheet model.  The Sheet model’s level settings should reflect what was saved in the Default model. 

Saved views also save the views extents.  So, when the views are updated from view 1 the drawings model’s “clip extents” are 
lost.  The first time this process is done the Sheet model’s clip needs to be re-established.  Open each Sheet model, used the 
Reference Files dialog box to highlight the referenced drawing model and then use the Clip Boundary tool and hit on the named 
Boundary to re-clip the reference file. 

Open each drawing and sheet model and make sure the reference files Display Overrides are set to Never. 

Additional levels can be turned on or off.  When finished Save Settings, Save the DGN and then CLOSE and Reopen it to see the 
changes.   
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P-6-3: Profile Cut Sheets 

Return to Index 

Introduction – Creating ORD Profile Cut Sheets Video 

Profile cutsheets are generated similar to plans in that a profile view seeds the create drawing models which in turn are referenced 
into sheet models.  They are generated in ORD using established procedures.  The seed profile view can contain a live cut through 
the attached reference file’s 3D models as well as displaying reference profiles of Drainage and Utility profile runs.  After creating 
the profiles the SuperElevation information can be annotated at the bottom of the profile using a special annotation group. 

Create the Profile CutSheet Drawing and Attach Reference Files 

Open ORD and use the file New command to create 12345-Prof-Seed.dgn in the \cutsheet directory.  Open the Default model and 
Reference file attach only civil drawing to this dgn including all drawings that have information to be drawn and annotated on the 
profiles.  This should include the E-Terrain, E-Drainage, E-Utilities, Geometry, and proposed corridors, as well as the P-Drainage, 
P-Utilities and the SuperElevation dgns.  Set the existing terrain model active.  Save settings and Save the dgn.  Either copy the 
dgn and rename it or use a File > Save As, to create 12345-Prof-Roadname.dgn.  The seed file can be copied to create drawings 
for other roads. 

Open Profile View 

Right click and hold on the screen and select - 3 Views Plan/Profile/3D from the View Control 
menu.  This will open 3 views with the two on top being the Default and Default-3D models.  Click 
OK in the pop-up box to create a Dynamic Profile view.  In View 1, as prompted Select the 
Alignment that you want to create the profile for and then click in the bottom View 4 to create the 
profile.   

If the command ends without placing the profile you may have hit on the alignment’s 3D geometry rather than the 2D alignment.  
Select the alignment in the Default model, reset or tentative snap as needed to ensure you hit on the 2D alignment, then hover on 
it and from the pop-up menu select the Open Profile Model and click in the bottom view to create it.  If having trouble turn off the 
display of the referenced Default-3D model and anything else under the alignment to be able to select it.  Save Settings and Save 
the dgn. 

https://engage.bentley.com/newhampshire-dot-resources/training/new-hampshire-ord-profile-cut-sheets
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Create Profile Named Boundaries 

Set the workflow to OpenRoads Modeling, Drawing Production > Named 
Boundary to open the Place Named Boundary tool.  Select the Civil Profile icon 
and set the Drawing Seed.  Next, click inside the profile view to start the command.  
This sets the Name and associates the stationing to the Start and Stop locations 
so they can be set.  Profile sheets should be 50 scale even if the plan scale is 20. 

 

 

The start location can be set in the view as the station value follows the cursor.  It 
is suggested that you key-in the start.  If you use the Lock to Start button at the 
right, it will lock to the start of the active profile not the start of where you may want 
a couple 100 feet before the proposed.  After setting the start station move the 
cursor to the right along the profile and boundaries will be displayed of the length 
indicated.  Change the length until the last sheet has about the same length as 
the rest displayed within its boundary.  The Default height is set to 160’.  If you 
intend to display superelevation information under the profile set it to 140’.  The 
Create Drawing box can be checked so the Create Drawing and Sheet Model box 
is displayed automatically.  Accept through the prompts to finish creating the 
Boundaries. 
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Create Profile Drawings 

The Create Drawing box should be filled in by default and no changes are 
needed.  If you want the drawing to automatically be added to the Sheet Index, 
check the box and then select the folder icon to the right to select the folder 
for the sheets to be added to.  Hit OK and the sheets will be created. 

 

 

If the Create Drawing box was not checked when creating the boundaries, the 
sheets can be created using the Named Boundaries tool box. 

Below and to the right of the Named Boundary tool, click on the down arrow.  
This will open the Named Boundaries box.  The drawings can be created by 
selecting the profile group name and clicking on Create Plan Drawing.  if the 
Show Create drawing dialog toggle is set, the create drawing box will appear. 
Click Ok to create the drawing and sheet models.  
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Add 3D Cut to Profile 

Open the profile view again from the View Groups menu selecting MultiModel Views.  This should return you to the 3 View setup 
with the profile at the bottom in view 4.  Use the View Tool and select Create 3D Cut.  The modes are Full Profile or Corners, use 
Corners as there seems to be a bug with fulll.  Place from top left to bottom right around the profile.  This will cut through all 
displayed features in the Default-3D model and show them on the profile.  The Drawing models and sheet model will automatically 
also display this information.  If there is a reference file you don’t want to display shut off its display in View 3.  Save Settings and 
Save the dgn, and refresh the 3D cut. 

NOTE: The 3D cut will display all levels in a reference file.  Levels can be turned off individually in the profile view, but you have 
to use Level Display and Expand the referenced Default-3D model’s levels to do it.  You cannot use Off by Element. 

For a list of things that should be in the cut see the Profile construction plan check lists.  
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Profile Annotation 

When profiles are created, they are annotated from the Annotation Group NH Prof Grid as selected in the Create Drawing Box.  
The alignments are also annotated by their assigned annotation group.  If the proposed vertical alignment changes, cutsheets 
don’t have to be regenerated unless you need them to be different length or have a sheet added.  The annotation just needs to be 
updated.   

Open one of the Drawing models.  A drawing model is where the annotation is created.  If you needed something moved, edited 
or added, this is where you need to work, in the Drawing model. To update an alignment’s Annotation, the annotation first needs 
to be removed from the drawing.  Set the workflow to OpenRoads Modeling > Drawing Production Tab > Annotations pane click 
on the bottom of the Model Annotation tool to show the dropdown menu and select Remove Model Annotation.  Check the All 
Drawing Models box and click on the screen.  To re-annotate the drawing select the dropdown again and select Annotate Model. 
Check the box for All Models and use the dropdown menu to select NH Prof Grid. Accept.  If the SuperElevations were annotated 
previously they will need to be re-annotated also. 

Adding SuperElevation Information 

If Roadway Superelevation sections have been created, they can be used to create the superelevation schematic below the profile. 
The Superelevation drawing must be attached to the Default model for them to be present to annotate.  Select the Model Annotation 
tool, Check the All Models box, and use the dropdown to select the NH SuperElevations annotation group.  Click on the screen to 
accept.  

The Resolve Aliases box will appear.  Superelevation lanes need to be 
attached to the Left and Right profile schematic lines by selecting the 
Targets in the Target boxes.  The names are from the SuperElevation 
control lines that were created and attached.  After defining the second 
target it is important to click in another box to ensure the second target 
is actually defined.  Click on the screen to Accept and create the 
schematics. 

 

Note: Only a left and right are defined. Development will need to be done to annotate more than 2 lines. 
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P-6-6: Creating Drainage Profiles for Plotting 

Return to Index 

Introduction – Create Drainage Profile - Video 

Drainage profiles are needed for complex drainage runs that cross other underground 
pipes and utilities.  They can be used to determine limits of excavation as well as to 
review depth of cover.  Not all drainage runs need to have profiles included in the 
contract. 

Drainage profiles should be created by following the Section on P-8-1 - Creating 
Proposed Drainage Features – Drainage Profile View.  The Actual Drainage profile 
needs to be created within the dgn that contains the Drainage and Utility Database.  The 
Drawing and Sheet models can be located in a different dgn.  These drawings can 
become rather large very quickly.  It is recommended that different areas of the project 
get modeled separately to keep the files smaller and working well.  

With the appropriate Proposed drainage drawing open use the Right click menu - View 
Plan/Profile then Cancel.  Open Explorer from the home tab and then open the Drainage 
and Utilities Model view in the explorer.  Expand the entries to get to the Profile Runs 
list.  Select the profile run, then right click and select Open Profile Model.  Click in the 
bottom view to open the profile. 

From the View Attributes tool change the Exaggeration to 1 and zoom into the profile.  
Use the Annotate Elements tool at the end of the view tools to annotation all elements 
in the profile.  (May need to zoom out or in to see the annotation).   

From the View tools select the Create 3D Cut tool and set to Corners accept and then 
drag a box around the profile to place it.  This will display all the elements from the 
Default-3D model into the Profile. 

  

https://engage.bentley.com/newhampshire-dot-resources/training/nhdot-ord-drainage--utilities
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Change to the Drawing Production Tab and select 
Create Named Boundary.  Drawing seed = Ansi 
D – Drn Prof 10,  Detail Scale 1”=10’, Vertical 
Exaggeration = 1, and then click inside the profile 
view.  Next update the start station Setting it to -
10, left click to accept (a box should then be 
shown), set the Profile Height = 50, and update 
the length as needed to encompass the profile.  
The Length should not exceed 300 as that is what 
fits on a landscape border.  The height and the 
top clearance can be adjusted to get the profile 
centered in the Box.   Update the name of the 
detail to include the station to station (or crossing 
station) value of the drainage run.  

Left click inside the view to accept each entry and 
bring up the Create Drawing Box. 
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The drainage profile models can be created in the same dgn or in a separate 
dgn.  Check the boxes next to the Filename and in the Drawing model use 
the green + to create a new drawing or the folder to select a previously 
created drainge profile drawing.  In the sheet model section use the folder to 
select the just create drawing to contain the profiles.  Set the annotation 
group to NH Drainage 10 Prof Grid and set the detail scale at bottom to 
1”=10’.  Click OK. 

 
The profile drawing and sheet models will be created in the designated 
drawing.  Text and labels can be added in the Drawing model and in the Sheet 
model, the reference file can be moved to the desired location. 

 

If adding an additional profile to an existing sheet the Sheets: toggle can be 
changed from (New) to the actual sheet name already created 
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P-6-7: Contour Creation (CTR and PCN) for plans from Terrain 

Return to Index 

Introduction  

Contours can be extracted from a STM (Scalable Terrain Model) or a TM (Terrain Model).   A STM can also be used to create 
HEC—RAS sections.  The STM can be created from several different sources including files, points, breaklines or ORD Terrain 
Models.  These combined STM can be exported to a TM, Contours Extracted or saved for future use.   

https://communities.bentley.com/products/3d_imaging_and_point_cloud_software/w/wiki/10678/extract-contours 

https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-microstation-contour-
from-terrain.mp4?csf=1&web=1&e=AbbZ6d 

Create A Scalable Terrain Model including an ORD Terrain Model 

Create \ Re-Create a new 12345ctr or pcn dgn using a 3D MicroStation seed file to contain the Contours in the \PRJ directory.  
The drawing should be opened into its Default-3D model.  Switch the workflow to Reality Modeling > Attach tab and select the 
Scalable Terrain Model tool in the bottom right of the Scalable Terrain Model pane.    

 

Select File > New… and name the STM with the name.  12345-E(P)-STM.stm 

https://communities.bentley.com/products/3d_imaging_and_point_cloud_software/w/wiki/10678/extract-contours
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-microstation-contour-from-terrain.mp4?csf=1&web=1
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-microstation-contour-from-terrain.mp4?csf=1&web=1
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The New STM Settings box will be displayed.  Set the Level, add a Description, 
contours-on, triangles-off and set the geographic coordinate system.  Click OK. 
This will create the STM. 

 

Next the Terrain model needs to be attached to the STM.  Use File > Modify to 
Open the STM Elevation Source Editor.  In the Editor use File > Add Terrain 
Model > DGN Level…  Select the attached Terrain and the E-Terrain level then 
click Select.  The Terain will be added to the STM but not visible.  This allows you 
to add additional terrains or other features to the STM if needed.   

Use Edit > Generate or click the Generate icon to display the generated STM. 

Close the STM Elevation Source Editor. 
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Create the Contours and Update the Symbology 

Use Element Selector to select the STM.  In the Properties box expand the Scalable Terrain 
Model’s Calculated Features and select Contours.  Change the contour interval as desired and 
set the precision to 0.  For existing contours set the smoothing to Spline, for proposed set it to 
none.  To remove the ‘ symbol from the contours use File > Settings > File > Working Units  click 
Custom to delete the Labels. 

Expand the Contours dropdown and set the properties of the 
Major and Minor Contours as shown. (P- for proposed) In the 
Scalable Terrain Model box, select Edit > Extract Contours.  The 
Extract Contour tool will display.  Use the Area drop down to select 
the mode of the contour boundary for Extraction.  Uncheck the 
Group in a cell box.  Define the Boundary to extract the contours 
and accept the extraction.   

 

Using the Scalable Terrain tool, the STM can be saved and 
detached from the drawing leaving the contours.  The text 
justification of the labels may need to be changed.  Use element 
selector and select all text in the drawing and use Change Text 
attributes to change the justification only to Top Right.   

Save and Exit the dgn.  
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Creating Proposed Terrain Models  
Return to Index 

Introduction 

Proposed terrain can be created from Elements using a graphic filter or by selecting the elements desired.  On long slopes this 
method can result in some slope waffling as the triangles try to connect to the nearest points of each feature rather than going 
from the top of slope straight to the bottom.  It is for this reason the preferred method is to build Proposed Terrain Models from the 
corridor meshes. 

The process is to reference all the meshes into the dgn, review them and copy any that need to be edited into the dgn.  They can 
be moved into different levels so they can be displayed independently and edited easily using the Edit Mesh tools.  Large meshes 
can be split into smaller pieces.  These referenced and edited meshes are then used to create a Terrain from Elements. 

If the referenced corridors or drives are updated in the future the terrain model can be updated by selecting it and updating from 
source.  Previously copied mesh elements can be removed from the terrain model, the updated ones copied back into the drawing, 
edited and then added back into the Terrain. 

A third method is to reference the design files and use the Create Terrain Model from Design Meshes.  The meshes don’t need 
to be displayed as part of the corridor feature definition, it will find and create the Top or Bottom Terrain from all the design mesh 
elements in the dgn’s that are referenced.  The drawback is that the Terrain may need to be edited which is harder than editing 
copied meshes.  

P-7-1: Creating Proposed Terrain Models from Mesh Elements 

Copy and Edit the Meshes 

The Corridor’s Feature definitions on your project need be set to either Concept 5X w/ Meshes or Final w/ Meshes so that the P-
Mesh-Top and -Bottom meshes are created.  This can be done on a Corridor by Corridor basis or the Explorer - OpenRoads Model 
tab can be used.  For linear Templates set them to Final w/ Meshes.  Surface templates have components for Top and Bottom 
Mesh elements. 

Open the P-Terrain.dgn.  Attach all files that are to be included in creating the Terrain such as the corridor and drive files as well 
as any other special plan files needed. 
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Open the Default-3D model.  In level display select all the reference files and turn off all levels and then turn on the P-Mesh-Top.  
Create a new level called 1-mesh, set the color, and then make active.  Review the mesh elements, copy any that need to be 
edited into the dgn.  Change their Level and color so they can be identified separately from others. 

Shut off the display of all the referenced files in the Default_3D display.  Create a new level 
called 2-mesh, set the color, set Active. Use Change Element Attributes to modify the display 
of alternating Mesh pieces.  Continue until no adjoining meshes are the same. 

WF > Drawing > Mesh Tab > Modify Meshes pane.  Select the Delete Mesh Facet tool.  Set 
the Type on the tool to Line.  Select the mesh to edit such as a drive radii mesh and draw a 
line across the overlapping slopes at the toe. Accept!  This will remove the overlapping mesh 
elements. 

Continue Zooming and rotating your view, identifying all areas of overlapping mesh elements 
and deleting the overlaps from the appropriate mesh.  Use any other mesh editing tools 
needed to update the models.  The Split Mesh tools can be used to separate mesh elements 
that cross a bridge area so that terrain for each side can be edited\created independently.  
The Mesh Utilities tab has the Cleanup Mesh tool that removes many facets of a terrain simplifying it. 

To view the results of your manipulations you can create a terrain 
model from elements and turn on the contours or flow arrows to view 
an area.  Delete the terrain when done and keep moving to other areas 
that need attention. 

When finished editing the meshes, turn on the display of any Reference 
files that contain mesh elements that did not need to be edited.  Fit 
view.  Select all the meshes needed for the terrain. Use WF > 
OpenRoads Modeling > Terrain Tab > Create from Elements tool.  
Feature type - Soft Break Lines, max triangles 20’ Feature 
NH_Design_Contours_1’_Minor, Accept. 

Shut off the all the mesh levels.  Review the terrain.  If any meshes 
were missed add them in. The referenced Design files linear features 
can be displayed to help review the terrain.  Right click and open 3 
Views.  Use the Default view to select the main corridor and Display 
Dynamic sections.  Move through the sections comparing the surfaces. 
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Editing Terrain Created from Meshes 

When Corridors or drives are updated the associated meshes are updated but the copied and edited meshes and the terrains 
created from them are not.  In some cases, it may be beneficial to just recreate from scratch depending on the amount of changes 
that have occurred since the Terrain was created.  If there are specific areas that need to be updated that can be easily 
accomplished. 

Open the DGN’s Default 3D model.  Select the terrain model and Update from Source to refresh the referenced mesh elements. 
Turn on the display of the reference files and compare the numbered mesh levels that it was created from. Delete any outdated 
mesh elements. Select the updated mesh elements from the referenced files.  Copy them into the view.  Edit the copied terrains if 
needed.  Use the Add Features tool to add them to the Terrain model. 

 

P-7-2: Creating Proposed Terrain from Graphic Filter 

Design and Subgrade terrain model surfaces need to be created for the cross sections.  These will also be exported in LandXML 
format for turnover to construction.  The Design terrain model and the existing terrain will also be combined to create a Composite 
terrain model for use with Drainage & Utility tools to design Proposed Drainage.  

When included with cross sections, the design and subgrade will be displayed with line weight 4 that the proposed sections should 
be drawn with. 

When a design is created by using one of the corridor templates, feature definitions are assigned to the elements being created 
(edge of pavement, top of slope, toe of slope, etc).  The process which is described here is dependent on the drawing containing 
those features.  Graphical filters select the features that would be used for a specific surface definition.  For example, the NHDOT 
Subgrade By Features filter selects features defining the bottom of the subgrade and toe of slope. 

• Open the 12345-P-Terrain.dgn, Open the Default-3D model.  Turn on the display of all proposed corridors created during 
the design process including drives.  

• Set the active level to Terrain_Coutour_Imported, color=9, linestyle 0 and line weight 3.   

• From the Terrain Model Task menu, select Create Terrain by Graphical Filter. See the sample form below while following 
the next few steps. 

• Select the ... button next to Graphical Filter Group and pick the filter group to use, NHDOT Design by Features.  Hit Preview 
to view selected features.  Under Triangulation Options, set the Edge Method to None or Max Triangle Length = 15. The 
Edge Method can be modified through element properties after the process is complete if the desired result isn't achieved 
on the first try. More details below. 

• Select feature definition - NH_Design_Triangles under the Terrain Display category.  Accept through the prompts. 
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Other Proposed Graphic Filters 

Repeat the above steps using the settings shown in the table below to create the Subgrade terrain model. Filters have also been 
created for creating surfaces representing the bottom of pavement and toe of slope boundary. 

 

Filter Feature Edge Method 

NHDOT Design by Features NH_Design_Triangles Max triangle Length = 15 

NHDOT Subgrade By Features NH_Subgrade_Traingles Max Triangle Length = 15 

NHDOT Bottom Pavement NH_SubPavement_Triangles Max triangle Length =   15 

NHDOT Toe Boundary NH_SubPavement_Triangles None 

The Maximum Triangle Length should be changed until the you have all triangles displayed... but so you do not have large slivers.  
The Maximum Triangle Length can be changed from the Edge Method section of the Element Information panel. 

 

The NHDOT Toe Boundary filter creates a terrain that only follows the Toe features.  Use the Extract Boundary tool to Extract 
Graphic which creates a Line String boundary from the terrain model.  It will put it in the active level and element attributes.  Use 
the Add Feature task to add the line string to design and subgrade terrains as a Boundary to more effectively clip out unwanted 
triangles. 

When the project is finalized and going to Construction, select the Design terrain model and right-click to display the Context 
Sensitive menu. Choose the Export to LandXML option. Fill in the prompts.  Repeat the Export for the Subgrade Terrain model. 

 

P-7-3: Terrian Tasks - Create Terrain Model from Design Meshes 

Reference the design files and use the Create Terrain Model from Design Meshes.  The meshes don’t need to be displayed as 
part of the corridor feature definition, it will find and create the Top or Bottom Terrain from all the design mesh elements in the 
dgn’s that are referenced.  The drawback is that the Terrain includes all mesh element even from components that are set to not 
be part of the top and bottom mesh line like the roundings.  Editing terrain is much harder than editing copied meshes.  To edit the 
terrain you need to drop the rules.  This still does not really allow you to use the Edit Mesh tools with any dependency.  The 
resultant Terrain can be dropped.  This will reduce it to a mesh element which can be edited with the mesh editing tools making it 
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much easier to trim down but deleting the roundings can take time along the whole project.  Prior to creating the terrain, all 
roundings could be set to 0 in the corridors so they are not part of the terrain but that would take a lot of time. 

The resultant terrain cannot be updated from source if the design is changed, they would need to be deleted and recreated.  This 
is a fast way to create the Terrain’s but may not be the best. 
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Drainage and Utilities 

P-8-1: Creating Proposed Drainage - Node and Link Features 

Return to Index 

Introduction 

Drainage and Utilities features are created for underground elements that need to be designed and shown on the cross sections.  
Drainage and Utilities features use both 2D and 3D cells (models) to represent their graphics.  The Default model of the drawings 
should be referenced into plan sheets and the Default-3D model referenced into the Cross Sections and Drainage Profiles. 

Bentley's OpenRoads Designer offers a Product Add-in for design and analysis of Drainage and Subsurface Utilities.    At the 
NHDOT we are not using the design and analysis functionality of this software at this time. 

This documentation will cover plotting proposed drainage and utility features, creating Drainage profiles and creating reports of 
these elements.    

Drainage and Utilities 

Nodes can be placed onto a surface (or other elements) to get the grate elevation. Follow the documentation for creating the 
Proposed Terrain model as well as creating a Composite Terrain model to be used by D&U. 

Open the 12345-P-Drainage.dgn, open the Default model.  Reference Attach the Combined.dgn with live nesting = 1 if not already 
attached.  Reference Attach the 12345-Composite-Terrain.dgn with no nesting.  Attach the Geometry, E-Terrain and any other 
drawings needed for the Design.  Use level display to set up your view as you want it and set the composite terrain model as the 
active surface.  Shut off the display of the existing terrain model so it is not accidently selected when trying to hit on the composite 
terrain model. 
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Project Properties 

The first order of business is to create the D&U database for the dgn by selecting from the Drainage and Utilities WorkFlow > Tools 
> Project tools > Project > Project Properties.  If this is the first time using D&U in the drawing, it will create the Utility model.  
Accept.  Fill in the Project Properties, then click OK.   

 

Proposed Drainage - Analyze Surface 

In Terrain Modeling task use the Analyze Trace Slope command (both Up and Down) to see where water is flowing.  The results 
should coincide with the displayed Catchment centroids from MX.  Turning on the High and Low points as well as the flow arrows 
from the composite terrain model will also help you determine the location of proposed structures.  It is suggested that you work in 
3 Views when laying out nodes and pipes. 
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Place Nodes 

Open the Drainage and Utilities WorkFlow Layout Tab > Place Node 
command to place the first node.  Select the appropriate proposed node 
such as P - CB 4ft Cone and follow the prompt to select a reference 
element for elevation by selecting the Composite Terrain model.  Accept 
the Placement Type, By Minimum Depth.  You can now use a data point 
on the screen to place the node, or activate Civil Accudraw, Station-
Offset, tab to highlight the Offset, then type an O (origin) and hit on the 
alignment as the reference element and then use the station and offset 
fields to type in a location to place the node.  Move the cursor around to 
define the nodes rotation and accept.  When using Civil Accudraw’s 
Station/Offset to place a node, the node will have manipulators for the 
station and offset to easily move it in the future. 

The command will continue to allow you to place additional nodes.  Just 
select the next feature definition you want to place and continue placing.  
Reset when done placing nodes.  Nodes should be placed for all 
structures including headwalls and end sections.  For links to be placed 
you must have a node for each pipe end.  In order for outlet ditch links 
to be placed, use the Conduit Drainage Node or Conduit Drainage Node 
Outfall to locate the end of the ditch or channel. 

For basins in pavement, the Vertical offset can be set to -0.08333 to 
achieve an accurate elevation.  Recall also that basins on pavement or 
in ditches are set 1’ inside the edge of pavement or CL of ditch 
respectively.  When placing Headwalls and End Sections use the -Pipe 
Diameter for the vertical offset. 

Nodes – Name and Base Reference 

A node is named from its Feature definition name base.  This is incremented for each one placed.  After placing all the nodes they 
should be Baseline Referenced to an alignment.  In the Drainage and Utilities Model section of the Explorer – expand the Nodes.  
select all nodes placed along a particular alignment.  In the properties box expand the Utility pane and click in the Baseline 
Reference box and then select the alignment to associate.  The Station and Offset boxes should populate.  Next select each node, 
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one node at a time and update the node name from an incremented value to the station value.  (PCB-1… to PCB-207+50).  This 
will help identify nodes when creating reports as well as Profile Runs that are generated. 

Place Conduit 

Use the Place Conduit command to place the pipes or ditches.  Select the feature definition (type of pipe) and then the size.  Each 
node has a connection area so when hitting on the node pay attention to where you are hitting on the outside of basins so they 
connect to the edge of the outside wall closest to the next node.  Place a pipe from the upstream node to the downstream node.  
Continue placing Conduit until all nodes are connected. 

Selecting a pipe will allow you to bring up the hydraulic properties.by clicking on Open Utility Properties. The Drainage properties 
for links contain all the hydraulic information about the link including the physical as well as the results after analysis/design has 
been performed.  A true/false switch is also available to tell the software if it is a culvert.   

Default settings for Proposed pipes have the Set Invert to Start and Set Invert to Stop set to True.  This means that when placing 
a pipe, it’s inverts will take on the invert of the node they are attaching to which could result in pipe not flowing down hill.  This 
setting can be changed (set to False) on a pipe by pipe basis or it can be changed in the Prototypes for all proposed pipes within 
the dgn.  

After placing pipes, select it and bring up the profile and change the inverts as necessary to get it to flow correctly.  A profile of the 
entire run can be generated from the Layout tab of the Drainage and Utilities workflow.  Either from the outlet or by nodes or links.  
The Drainage Profile run will be shown in the Explorer’s Drainage and Utilities Model tab.  Right click on it to select it and then 
Open Profile model.  The nodes and pipes should be selectable and editable within the profile view. 

Drainage ditches are Conduit links and can be placed from the last outlet structure to a Pipe End Drainage Node placed on the 
surface of the terrain.  Bring up the profile and modify as needed.  With the pipe selected the Trench can be turned on to create a 
corridor. Selecting this and drilling down into it allows you to see the Template it is using and change it to what you need.  There 
are several Ditch templates that can be used.  Selecting the corridor object tools then the corridor allows you to control all aspects 
of the ditch.  The V ditch shapes level P-Util-Drainage-Conduits-Ditch-3D can be turned off in the Default-3D model leaving only 
the trench corridor displayed. 

Drainage Profile View 

A profile of the entire run can be generated from the Layout tab of the Drainage and Utilities workflow.  Either from the outlet or by 
nodes or links.  Set the Feature definition to Geometry Pipe Run.  The Drainage Profile run will be shown in the Explorer’s 
Drainage and Utilities Model tab.  Right click on it to select it and then Open Profile model.  The nodes and pipes should be 
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selectable and editable within the profile view.  The pipe run should be renamed to the Start and End Station node values so it is 
easily identifiable.  Update the scale and create a 3D cut to see the referenced 3D model information along the profile.  The 
annotation button (all elements) can be used to show the Pipe and Link annotation.  You may need to turn on Annotation Scale 
and set the scale to see it.   

Cover or subsidiary excavation depth can be checked from the profile view by either the measure distance command or by the 
Profile Creation tool – Profile from surface. The vertical offset from the Existing Ground terrain can be used to create a profile line 
4 feet below for cover as well as a second line 9 feet below to check for excavation areas.  The line styles and other symbology 
can be updated for clarity of those lines. 

Selecting the Profile run in Explorer allows you to update the Node Draw Type to slice if you have it set to something less desirable.  
Drainage profiles should show the Proposed ground the existing ground as well as all subsurface features from the project.  What 
is globally displayed in the Default-3D model is what is displayed in the profiles’ 3D cut. (may need to be updated though).  To shut 
off the display of say the corridors select materials, open the Level Manager, (If needed Turn on the column for Global Display by 
Right clicking in the top line of the level view and checking next to Global Display.)  In the Tree, select the drawings 3D entry to 
display the levels in that corridors drawing and Turn off the levels for XC-CRGR , XC-Gravel, and XC-Sand by unchecking them.  
Save Settings, Save the dgn and it may require reopening the dgn as well as refreshing the 3D profile cut for the view to sync. 

See the Cut Sheet documentation to learn about creating sheets of the profiles.  

 

 

  



 
 

NHDOT CAD/D Connect Documentation 

ORD Design Documentation Page 81 of 93 Last edited:  February 15, 2024 

P-8-2: Existing and Proposed Utility Poles 

Return to Index 

Introduction 

Item Type information can be attached to the Existing poles in the 12345-E-Detail.dgn as well as the proposed poles to help with 
annotation as well as with Reporting.   Upon Receipt of the Utility pole relocation sheets this can be started.  Proposed poles 
should be plotted in the 12345-P-Utility.dgn using Civil Accudraw to ensure the station and offsets are correct as well as to have 
them as manipulators if they need to move in the future.   

Existing Utility Poles – Add Item Type Utility Pole Location 

Open the E-Detail.dgn’s Default-3D model and use Element Selector to select all Annotation Cells and then switch to level and 
unselect everything that is not a utility pole.  Use the Attach Item tool and add the Utility Pole Location Item to all the poles.   

Follow the XS-Detail procedures to create tick marks for the existing detail.  

 

Open the E-Detail.dgn - Default-3D model 

Shut off all detail - turn on only poles     E-Utility-   levels 

 

Select and add item type data - pole location 

report the pole locations and save to an Excel file.  open the Excel file on the side. 

 

attach the corridor, and or the P-Terrain geometry drives and such 

 

  Terrain > Edit > Boundary options > create boundary > Extract Graphic >  select the terrain. 

   Fence from element  
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In the Default view shut off all except the poles, alignment and the corridor.... can use just the alignment vs the corridor for dynamic 
sections. 

 

Open 3 views - place dynamic section in the lower view.  Alternately, you could add Event points to the geometry and use that to 
cut section at the pole locations. 

 

Locate station via data point -  select the first pole. 

In the section view, go to the pole offset and scale the cut or fill amount and fill in on the Excel table. 

 

Repeat for each pole location. 

 

When done, set the Default 3D view active - shut off all but the poles and then select each one and add the cut / fill height to the 
Pole Location item. 

If in Top View you could also attach the ETXT dgn and add pole numbers to the item info 

 

When done create a new report. 

 

The report can be used in the Geometry dgn to create an event point list of all the poles so a set of sections can be cut showing 
the cut & fill amounts for utility sections use. 

If the XS-Detail has been created, the even station sections could be used. 

 

Give the report to the utilities engineer with pdf sections for pole L/R determination format in Excel 

 

 

When you receive the pole relocation sheets, open the Default-3D model select each pole and add the L/R information to them. 
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Reselect poles that are not on a particular alignment and then use Asset Manager to attach a Linear Reference.  Repeat for each 
Road that has poles on it.   

 

Reselect all the poles and use the Utility Pole 
Relocation sheet and the Properties Box to 
move thru the list of poles and Assign a L/R/P/T 
- Leave or Remove label to each.  These 
designations are also used to Label the poles 
in the P-Utilities.dgn.  With the ETXT.dgn 
attached, the Pole number can be added as 
ItemType information as you move down the 
list.  Right click on the Annotation Cell and 
Zoom to each particular pole in top view to see 
the pole numbers. 

 

View dynamic sections to review the Grade 
Change information and add to the Item Type 
entry and verify on the Relocation sheets.  Use 
the View Station Via Data point and hit on each 
pole with an Origin Hit code to view the section. 

  



 
 

NHDOT CAD/D Connect Documentation 

ORD Design Documentation Page 84 of 93 Last edited:  February 15, 2024 

Plotting Proposed Utility Poles 

Open the Drainage and Utilities WorkFlow Layout Tab > Place Node command to place the first node.  Select the appropriate 
proposed node such as Electric Nodes >  P_Joint Pole and follow the prompt to select a reference element for elevation by 
selecting the Composite Terrain model.  Accept the Placement Type, By Minimum Depth.  You can now use a data point on the 
screen to place the node, or activate Civil Accudraw, Station-Offset, tab to highlight the Offset, then type an O (origin) and hit on 
the alignment as the reference element and then use the station and offset fields to type in a location to place the node.  Accept 
or change the Rotation Mode, then move the cursor around to define 
the nodes rotation and accept.  When using Civil Accudraw’s 
Station/Offset to place a node, the node will have manipulators for the 
station and offset to easily move it in the future. 

The command will continue to allow you to place additional nodes.  Just 
select the next feature definition you want to place and continue 
placing.  Reset when done placing nodes. 

When working on poles it is sometimes hard to differentiate between 
existing and proposed.  Use the right click menu and select View 
Control > Ref Adjust Colors to tone down all the reference files and 
more easily see the proposed poles.  

 



 
 

NHDOT CAD/D Connect Documentation 

ORD Design Documentation Page 85 of 93 Last edited:  February 15, 2024 

can open the geometry.dgn and add all proposed pole stations from the Pole Relocation sheets to a proposed pole event point 
list 

 

Open P-Utilities.dgn 

Attach alignment corridors and existing terrain  

default view.   

 

D&U place node 

use civil accudraw and place poles 

attach station and offset - Node item type  or pole location item type.   

Dynamic sections could be viewed to determine cut/fill height at the proposed locations 

 

create a PFSONEE report of the proposed pole vs the alignment  

 

open the xs - detail dgn and create all the ticks for all detail or just for the proposed poles 

 

create sections of the proposed and existing pole locations  could leave the named boundaries in the p-util and save the sections 
to a different dgn 

remember that pole tick marks are at the even station not at the pole station. 

 

Attach the Gen Plans Cut sheet drawing for Sheet Named Boundary locations.  rotate to the first sheet. 

Use the PUT task list to label each existing and proposed pole location. 

 

For existing poles... manipulate levels... then "highlight" reference file 
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For proposed.... asks for identify element.... tentative on the alignment then accept to highlight it.... then use origin code on the 
proposed pole.   

Rotate to each sheet. 

 

Place Utility Pole Notes  

Reference the Default model of the cut sheet drawing that the pole notes will be plotted on into 
the Default model.  Use the Named Boundaries to rotate the view to each cut sheet prior to 
adding the notes for that sheet.  Open or use the NH_PUT Tasks.  There are 2 sets of tools to 
label Existing and Proposed Poles one for MSC and the other for ORD.   

The MSC tools use Place Note for the L/R, and the Station/Offset macro for the Proposed poles. 

The ORD tools use the Place Label command and pull the information from the node or Item 
Type properties attached to the nodes or cells.   

For L/R notes Select the Tool then Origin hit on the Existing Pole.  For MSC type an L or R in 
the text editor and then click where to place the Text.  For ORD after selecting the pole just 
place the text.  
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For the MSC Proposed Utility Pole Notes the tool will Open 
the Station/Offset Macro.  Use the Select Center Line 
Element  and select the alignment, and accept.  Update the 
Begin Station and change the Type to Utility Partial Sta. 
and Off.  Click Place Label and use an Origin hit on the 
pole and then place the label.  Repeat for each Proposed 
Pole.  Remember to rotate to each cut sheet as you 
proceed. 

 

 

 

For the ORD Proposed Utility Pole Notes the tool will 
Open the Place Label tool.  In the bottom left it will 
prompt you to Identify Element or Data Point.  
Tentative Snap to the alignment to highlight it then 
Left Click to select it and again to accept it.  Next use 
an Origin hit on the pole and then place the label.  
Repeat for each Proposed Pole.  Remember to 
rotate to each cut sheet as you proceed. 

 

 

When finished Save Settings, and Save the DGN.  

https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/SitePages/Station-Offs.aspx
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Label Cross Section Slope 

Macros 

It is suggested to match element attributes as well as text attributes to another slope label 
prior to using the macro. 

To Label a slope on a Cross Section that did not get labeled.  WF > Drawing > Utilities 
Tab > Macros Pane > SlopeSet  <PLAY> 

Update the settings as desired. 

Command text will show in the message center indicating Select First Point, Select 
Second Point, then Select Text Location.  
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Rotate Cells – Envision CADD 

Introduction – EnvisionCadd – Rotate Text and Cells - Video 

The Envision CADD software has been added to the NHDOT Workspace.  If using the default setup a 
Text ToolBox with 3 tools will be available, Label Areas, Rotate Text and Change Case.  

There is also anEnvisionCAD workflow to get these and other utilities. 

EnvisionCad - https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-
Home/CADD%20Document%20Library/envision_text-
rotation.pdf?csf=1&web=1&e=QEERut 

This tool is intended to rotate Text (Cells) to the View Angle.  So first rotate the view along the roadway.  
In a 3D model rotate by 3 points.  Hit all points in space so they get the same elevation, the first 2 define 
the rotation, the last point hit above the other two.  Return to Top rotation and re-rotate if you hit on an 
element and tilted the plane. 

Use Element Selector to drag box around cells or text you want to rotate.  Click on the A Rotate Text tool 
and use the following Settings - Rotate by Angle, Reverse View Angle - uncheck/check to update view 
angle, Absolute, check Rotate entire Cell, click UPDATE to Rotate them.   Note that poles on the bottom 
side of the roadway will need to be selected again.  In the Tool add 180 to the Z Rotation value and then 
Update.  

 

  

https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-envision-rotate-cells.mp4?csf=1&web=1&e=MnzS9W
https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/envision_text-rotation.pdf?csf=1&web=1&e=QEERut
https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/envision_text-rotation.pdf?csf=1&web=1&e=QEERut
https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/envision_text-rotation.pdf?csf=1&web=1&e=QEERut
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Quantity Computations 

P-9-1: NHDOT Suggested Practices 

Return to Index 

Introduction 

With good 3D modeling comes good quantities!  That is not to say that errors won’t occur and we do describe a bug below.  Create 
Quantity dgn files for your work.  if you already have Cross section dgn’s, make copies of them for quantities so the main project’s 
dgn files are not disturbed. 

For Select materials and such use, Corridor Component quantities.  Any clipped areas will need to be adjusted by hand. 

Earthwork Quantities from the Cross Sections 

Quantities from Cross Sections is the historical method of computing the earthwork.  But, in order to compute complex areas 
around bridge pay limits and side roads with match lines, a separate set of sections should be created just for Quantity Calculation 
purposes.  These special sections can be cut with additional half width areas to accommodate Back and Ahead areas to more 
accurately compute the volumes.  Alternately, Plan name boundaries can be created 50 feet long and half to the left and another 
group to the right.  The shapes can be modified and the resultant cut and fills computed.  QML lines drawn along the edges in the 
plans will show on the cross sections.   

Earthwork Quantities from Named Boundaries 

Quantities from plan named boundaries allow for computing odd shapes around bridges and sideroads.  They can also include the 
drive components.  By creating them at a 50-foot interval as well as on the left and right of the CL allows them to be easily modified 
to ensure coverage of the whole project.  
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BUG – Select Materials – Sand, Gravel, and Crushed Gravel 

ORD 2021 Release 2 has a bug when computing quantities that have component name override locks active.  The intent of the 
name override is to fill in the gaps between component drops making the quantities more accurate.  But this is giving incorrect 
results from End Area Volume Reports from the cross sections as well as the Plan Named Boundaries.   

From XSections AverageEndAreas   From plan Named Boundaries  From Component Quantities 

   

The errors seem to be contained to components that have display rules for multiple component decision making.  Meaning 
Transition components for Sand, Gravel, and Crushed Gravel.  While Component Quantities seem to be the most accurate 
“Clipping is not Considered in Quantities”, and adjustments have to be made by hand to any clipped areas.  Corridor Component 
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Quantities should only be created in the same dgn as the Corridor.  Incorrect results are returned when reporting on a referenced 
corridor.  This seems to be caused if the terrain is not set active. 

 

After using Create EarthWork Volumes then the Cut and Fill volumes from the XSections Average End Areas are correct and can 
be used.  For areas with side roads and drives that may need a Quantity Match the Plan Named Boundaries can be placed and 
modified.  The resulting volumes for cut and fill from the plan Named Boundary can be used/incorporated into the Average End 
Area report to compupte the final numbers.  


