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Getting Started with MicroStation Connect 
 

MicroStation CONNECT Training  

Many MicroStation training lessons exist between Bentley’s LearnServer, Communities videos and YouTube channel.  Lessons 
on the LearnServer can usually be downloaded to the local computer.  NHDOT staff should visit the CAD/D Training page for 
details on additional options.  Bentley has a YouTube channel with MicroStation Connect training videos.  See the full playlist at:  
https://www.youtube.com/c/BentleyMicroStation/playlists?view=50&sort=dd&shelf_id=2. 

 

Updating MicroStation SS4 files to CONNECT 

Return to Index 

Before You Begin 

This process is to update SS4 MicroStation drawings to MicroStation Connect.  NHDOT staff must have a Connect Edition project 
created by the CADD staff to use.  You should not use MicroStation Connect or OpenRoads Designer to work on SS4 files in an 
SS4 project.   

SS4 linestyles are typically not visible when opening the drawing in a Connect version product.  This is intentional so you know 
that they need to be updated.  A macro has been developed to make the conversion. 

https://nhgov.sharepoint.com/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nhdot-ce-cadd-documentation_microstation.pdf?view=50&sort=dd&shelf_id=2
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Open MicroStation CONNECT – Attach and Merge DGN from SS4 Project 

CONNECT Edition elements are set up to use Annotation scale.  Drawings that were populated with SS4 elements need to be 
updated to use the new levels, linestyles and fonts as well as having Annotation scale on for all models and cells. 

Open 

MicroStation CONNECT.  Set the workspace to NHDOT and the Project to yours.   
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Model information on the left is from an SS4 model, on the right is 
a MicroStation Connect model.  The primary differences are the 
linestyle scale and the Solid Area.  The solids area was updated 
per Bentley for use with 3D Bridge Models that need a higher level 
of detail. 

 

Some projects created during the early stages of the transition 
have MicroStation drawings in the PRJ\ folder created from an old 
MicroStation seed file.  These should be replaced with new files 
created from the MicroStation Connect seed file 
NH_Seed2D_Design.dgn.  The seed project has been updated 
but it is wise to check if you know your project was created before 
May of 2019.  It is best to move any SS4 files to a separate folder 
so they will not be confused with Connect files in the future. 

To convert SS4 data to Connect, create a new file with the Connect 
seed file which will ultimately replace the current drawing.   

Once the new file is created, it will open.  The next step is to attach 
the corresponding SS4 drawing as a Reference File.  Turn on all 
levels in the active view.  In the Reference file dialog box, select 
the dgn file name and use Tools > Merge into Master.  Click on 
the screen to copy the detail into the new CONNECT drawing.  This 
will also detach the reference file. 

If the drawing contains design data which needs to have Feature 
Definitions applied for use in OpenRoads Designer, see the SS4 
to Connect Project Conversions section at the beginning of the 
OpenRoads Designer Survey documentation to continue this process. 

Changing Levels, Linestyles and Fonts 

Now that the MicroStation graphics are copied into the drawing, they need to be updated to the correct attributes.  Note that lines 
with the Arrow linestyle may have huge arrowheads.  This is due to the line style scale being multiplied by the annotation scale.  

https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nhdot-ce-cadd-documentation_ord-survey.pdf?csf=1&web=1&e=7gf6Zj
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To replace SS4 linestyles with CONNECT ones, run a macro called CnvLines2Connect.  Macros can be found within the Utilities 
tab of the Drawing workflow.  Select the macro from the dropdown list and click Play. 

 

Level names and fonts have also been updated in CONNECT.  A macro called CnvLevels2Connect has been developed to move 
elements to the new levels.  Then CnvText2Connect modifies text by changing the nh_engineering font to a text style which 
uses the Engineering Vert Mono font.  It also turns annotation scale on for the text elements and resizes them according to the 
annotation scale set for the drawing.  Depending on the settings of the drawing, some text may become unusually large or small. 

A fourth conversion macro - CnvCells2Connect - has been developed to substitute v8i cells with their Connect equivalents.  To 
simplify the conversion, most Connect cells retain the names of their v8i predecessors.  If the macro is not able to find appropriate 
replacements for particular cells, it puts that information in a file called unedited-cells_drawing name.txt in the same folder as the 
drawing. 
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Right-of-Way Text Drawings 

Using the macros (except CnvCells2Connect) above may not be entirely successful on older Right-of-Way text 
drawings.  In particular, the parcel and lot cells may not update to the new cells and styles.  To manually edit these, 
select the cells on the drawing and issue the Change Text Attributes command.   

 

Set the Font to Engineering Vert Mono 

Set the Height and Width to 0.009 

Set Line Spacing to 0.8 

Check the box at the bottom for Annotation Scale 

Click within the drawing area to accept the changes. 

You will also need to update the levels, to do this, select everything on your 
drawing, click on show extended setting in the extended setting with everything 
selected, you can deselect levels to isolate the one you want to change  
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With the level you want to change selected, in this case the parcel number, on the task list click on parcel number.  This is to set 
the correct level.  With the correct level set, issue the change element attributes 
and accept the selection on your screen.  Repeat this for each level you want to 
change.  
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MicroStation Connect - MSC 

P-7-1: Working in MicroStation Connect 

Return to Index 

Prerequisites 

Must have MicroStation Connect Installed and have your user profiles created by a member of the CADD Staff.  Additionally, a 
Connect edition project should have been created for your use.  Connect Edition project files should be kept separate from v8i 
files.  When a project is converted from v8i to Connect, NHDOT has been appending the old folder name with “-SS4”.  Those 
projects and files use different settings for Global linestyle scale and do not use annotation scale as well as using different levels.  
You should not use MS Connect to work on SS4 files and vice versa.  

Most user settings should already be defined from the Default configuration.  Open MicroStation and select Workspace: NHDOT 
and then the Project. Next either Browse to open an existing drawing or select New to create a new dgn in the appropriate directory.  

Working in MSC – The ribbon 

 

When MicroStation opens you will see the ribbon across the top showing the different tabs of the Drawing Workflow as indicated 
in the upper left. To the right of the Workflow the Select V8i Mode button can be used to set/change Task’s modes.  Use the Dialog 
setting for the Task Lists that are similar to the SS4 Task Lists specific to each drawing.   

On the Help Tab you can select Help Contents to view the information on all of the MicroStation functionality which will not be 
covered in the NHDOT CADD Documentation.  It is suggested that you review the information found in the Help Contents.  Much 
of the work you will perform can be done from the Tabs found on the Drawing Workflow while using the element templates.   
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Element Templates – Defining Element Attributes 

When drafting the Home tab’s first pane - Attributes shows the element template dropdown list 
with the level and other element attributes.  An element template can be chosen from the list 
setting all the element attributes and then an appropriate command can be used to draw the 
desired element.   

The Element Templates list is divided up similar to the drawing types.  Expand the Prop 
Templates folder to see the templates that have been defined.  The P-Road folder contains 
templates for Travelled Ways, Edge of Pavements, Cut/Fill Lines and other roadway elements.  
Other element templates for PLY features can be found in the PLY Temp(lates) folder.  Recently 
used templates can be found at the top.   
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The Element Attributes tool bar can be opened and docked below the ribbon on the left (by default 
– can be moved) and can be used to select the Element Template when not on the Home Tab.  
Most element templates use By-Level settings and can be associated to the graphics drawn, 
though this is not necessary.  The element templates may also include text styles, dimension 
styles, possible overrides as well as cell names and scales. 

An optional way to draft elements is to have your attributes set to By-Level and just set the active 
level appropriately.  This will not define any text styles or cell names but is a valid work flow as 
all the levels exist with their attributes defined. 
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Task Navigation – Select V8i Mode 

The WorkFlow in the top left can be set to Task Navigation.  Beside the 
WorkFlow the Select V8i Mode drop down list can be used to select the 
mode desired.  These tasks are similar to what was used in V8i.  Meaning 
that they will set the Element Template – defining the element attributes as 
well as giving a Key-in command to activate the most common tool for the 
type of element you have selected.  For instance, when selecting Fill Slope, 
it will activate the Place Line command and for a Clearing Line it will 
activate the Move/Copy Parallel command. 

Selecting Ribbon will change the workflow to Task Navigation and load 
the current task list inside the ribbon with the mode button allowing the 
different task lists to be selected.  To change to a different type, the 
Workflow would need to be changed back to drawing or general. 

The ComboBox option is shown.  It can be docked as a regular tool box.  
The first button allows for selection of the task list.  The second button 
selects the specific task and clicking on the last button Run Current Tool 
enacts it. 

The Tool Box option shown below can be docked but can present issues as it is not a set width.  Its size varies with the length of 
the task list.  Task sub menus within it can be hard to determine as they are shown with a Tool picture. 
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The Dialog option brings up the Task list as it appeared in SS4.  Next to the Task list name 
is a dropdown used to select the specific Task list you want.  

The Task list can be docked and pinned closed on the right side of your session.  Hover over 
it to expand it, and pin it open if desired. 

The list can be changed by selecting the dropdown (black triangle) next to the title of the task 
list.  Change it to match the drawing type that you are working in.   

When using the tasks or any Element Templates to create features, please report any issues 
or changes which you feel are appropriate to a member of the CAD/D Staff. 
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General – Search Ribbon, Tool Boxes and Tools 

While the most common tools are set for each Task in the Task Lists, the Drawing 
WorkFlow can be used to select other tools.  In some cases, switching between 
them looking for tools can be frustrating as well as time consuming.  In the top 
right had corner of the ribbon is the Search Ribbon (F4).  Click inside the blank 
box and start typing the name of a command.  As you type, common tools fitting 
the characters are displayed.  Hovering on them expands them to shown what 
Ribbon the are located on for future reference.  Select the tool to activate it. 

 

An additional way to locate and use tools it to type Tool into the box which will 
bring up Tool Boxes as a choice.  Click on Tool Boxes when it appears in the list.  
This will bring up the Tool Box selection list.  Select any tool boxes from the list to 
open them, click OK to close, then move and dock the tool boxes where you want 
them. 

 

The most commonly used commands can also be found 
on the Space Bar Pop-up.  With Element Selector active 
and your cursor in a view, press the Space Bar. This Key 
Board Shortcut will display the Popups tool selector.  
Select a command, the tool will activate.   

 

If the tool icon contains a symbol in the bottom right, clicking on it will actually bring up a new tool 
box of the associated commands which can be selected.  
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Quick Access Tool Bar 

The Quick Access Tool Bar is located at the top of the screen next to the WorkFlow selection box.  It contains some commonly 
used commands and can easily be modified to remove or add additional commnds by clicking on the last button Customize Quick 
Access Toolbar.  By clicking on the last button in the toolbar you can also hide/unhide commands using the check marks next to 
each tool. 

 

Return to Index 
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P-7-3: Creating Detail Sheets – For Proposal Projects (8½" x 11") 

Return to Index 

Before You Begin 

Determine what and how you want to sheet and start at the appropriate section.  Sheets along an alignment, from clipping 
references, or from 2 points, are three difference workflows.  A variable in the projects .cfg file can be defined to set the default 
sheet size.  MS_SHTSIZE = A   defines the size of the sheet models when creating plans.  The Options are D-22x34, B-11x17 
and A-8.5x11. 

Open MicroStation Connect – Select the NHDOT Workspace and select the Project. 

It may be helpful to open the Drawing Scale tool box and the Key-in tool and dock them. 

Create a Detail or Typicals DGN 

Use the New File button to create a new dgn file.  Verify the Seed - NH_Seed2D_Design.dgn, set the file directory and enter a 
name for the file with the project number as a prefix.  (12345Details)  

If only one detail is to be on the sheet, create your graphics in the Default model.  If multiple details at different scales are 
needed, create new models to place each detail in and leave the Default model blank. 

Use Element Templates to set your symbology and draw your detail using the standard 
MicroStation commands.  Task lists exist to assist in assigning symbology and plotting cells.  
To open a task list, set the WorkFlow to Drawing if it isn’t already.  Note the V8i mode button 
immediately right of the WorkFlow dropdown.  Click on it and select Dialog.  Change to a 
different task list as appropriate.  NH_TYP Tasks can be used for typicals.  When ready to 
dimension or label the detail, the sheet size (scale) should be determined.  

Determine Annotation Scale and place the Border 

Set the annotation scale to Full Size 1=1.  Open NH_BDR Tasks.  Select the 
Sheet Stuff category and then either Border 8.5x11 Landscape or Border 8.5x11 
Portrait.  This will start the Place Cell command with the active cell BDR-
CUTSH-C.  Change the cell scale until it encompasses the detail... 48, 60, 120, 
240, 600, 1200.... change the scale back to 1 and Reset to not place the cell.  
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Enable Annotation Scale if is not already activated and set it to the value determined by dividing the scale number by 12 to 
calculate the inches to feet annotation scale. (i.e. 120 / 12= 1” =10’).  Select the 8x11 
Border task again and place border cell.  The cell will take on the annotation scale size 
as appropriate. 

Select all the elements in the drawing and use the Move command to move the 
graphics from the bottom left corner of the border and Keyin    XY=0,0   and press Enter 
to move the detail.  Right click to end the move and then Fit View. 

Continue working on the detail placing text and dimensions making sure to use Text and 
Dimension Styles as the annotation scale will size them correctly.  Tasks can be 
selected from the 8x11 nh811typ Task list to create text and dimension lines. 

Create the Named Boundary and Detail Sheet Model  

When ready to create the actual Sheet model, set the element template to 
Modeling\Sheets\Named Boundary. 

Set the Workflow to Drawing, View tab, and select the Place Named Boundary tool.  
See the graphic for recommended settings.  Type:  By 2 Points.  Name:  DETAIL.  
Place single (picture top left).  Group:  (New) or none.  Name:  Details.  Check the 
Create Drawing box.  Click on opposite border corners then click in the view to 
Accept. 

In the Create Drawing box – Name the created sheet - this will show up in the sheet 
index as well as the model name.  Set the Drawing Seed to 
Detail_2D_English_SheetOnly.  Change the Annotation Scale and the Detail Scale 
to the scale of the border.  Check the Add to Sheet Index option and select the 
folder if desired.  Click OK. 

Results 

This creates callout links in the design model to the cut sheet model, as well as a 
saved view of the sheet within the DGN and a new Sheet model which is used for 
printing. The sheet will also be added to the Sheet Index if you checked that box. 

Return to Index 
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P-7-4: Creating Plan Sheets - For Proposal projects (8½" x 11") 

Create\Open the 12345mth.dgn.  This file will contain the clipping elements as well as being used as the seed dgn for the cut 
sheet drawings. 

Attach References 

Use NHREF macro to attach the project’s roll plan drawings.  Set the annotation scale to 1"=100'. 

Determine whether to create your cut sheets A - along an alignment, or B - from clip area boxes placed in some matrix layout.  

A - Create Named Boundaries Along Alignment 

Set the element template to Modeling\Sheets\Named Boundary and 
enable the Associate Element Template button.  A continuous line must 
exist through the project to place the sheets along.  

Use Drawing Workflow’s, View tab, Place Named Boundary tool.  Choose 
the By Length option and see the graphic at the right.  Name:  CUTSH 1.  
Select the Place Along Path button.   Group:  (New) or (none).  Name:  CUT 
SHEETS.  Length: 1000, Offsets: 275.  Uncheck the Create Drawing box so 
only the named boundaries are created.  Select the Path element at the 
location of the first named boundary, this will display the first cut sheet 
outline.  Move your cursor along the path displaying the sheet indicators to 
the desired location of the last border and left click to create the named 
boundaries.  If the Create Drawings box pops up just close it without creating 
the drawings! 

Other alignments can be selected to create additional named boundaries.  
The named boundary elements can also be modified where side roads 
intersect to avoid overlaps. 

When finished creating the boundaries, Save Settings and Save the dgn.  
This is the Project’s CUT SHEET SEED file!!! 

Skip procedure B and proceed to Create Cut Sheet Drawing. 
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B - Create Named Boundaries from Clip Boundary Elements 

Use NH_BDR Task Clip Boundary to set the symbology of the clipping boxes.  
Rotate the display and use Place Block with the polygon option to create a clip area 
box, 1000 feet long by 600 high if using 1"=100' with 8½" x 11" sheets.  After 
placing the box, copy it until the desired area is covered. 

Set the element template to Modeling\Sheets\Named Boundary and enable the 
Associate Element Template button.   

Create a named boundary of each Clip Boundary using the Drawing Workflow’s, 
View tab, Place Named Boundary tool using the settings shown at the right.  By 
Elements setting.  Name:  CUTSH 1.  Select the Place Single option (picture top 
left).  Group:  CUT SHEETS.  Un-Check Create Drawing.  Select one Clip Boundary.  
This will create a named boundary and change the clip symbology to that of a 
Named Boundary.  The name should automatically increment the boundaries.  

When placing subsequent boundaries select the Group that was created when 
you created the first named boundary!  Keep Creating the Named Boundaries until 
all the placed clip outlines have been done. 

When finished creating the boundaries Save Settings, and Save the dgn.  This is the 
Project’s CUT SHEET SEED file!!! 

 

Create Cut Sheet Drawings 

If still in the 12345mth drawing, use a File > Save As command and save the dgn into the POP folder with the name of the type 
of cut sheet you want to create.... 12345-GenPlans, 12345-DivPlans or 12345-PavPlans.  Optionally in windows explorer copy 
the 12345-mth drawing to the POP folder to create the different cut sheet dgn drawings.  
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Open the Cut sheet drawing.  In Drawing Workflow’s, View tab, 
Open the Named Boundaries tool box by clicking in the bottom 
right of the Named Boundary Group.  

In the named boundaries box highlight the group name and 
then click Create Drawing. 

In the Create Drawing box - Set the Name to GENSH 1... or 
PVTSH 1.... set the drawing seed to 
Detail_2D_English_SheetOnly. 

Change the sheet’s Annotation Scale and the Detail Scale to 1"=100', the 
scale of the design model. 

Check Add to Sheet Index and select the folder if desired, then click OK. 

Results 

This creates callout links in the Default model to each cut sheet, as well as a 
saved view of each sheet within the DGN and new Sheet models which are 
used for printing. 

 

Additional Cut Sheet Work 

Set the WorkFlow to Task Navigation, Select Task - V8i Task Theme then in 
the task list select the NH_BDR tasks.  

Open each Sheet model in turn and perform the following tasks 

Fit View, Use the task Place cell - BDR-8x11 Landscape 

Place cell scale bar -  BDR-ScaleBar50 

Key-in REFERENCE SET NESTOVERRIDES=NEVER or in the reference file 
dialog box select the attached Default model and set the Display Overrides to 
Never. This will keep the display of all the sheets in sync with the display 
settings of the Default model.  Move the Reference file up a little as needed. 
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P-7-5: Front Sheets 

Return to Index 

Reference the Detail Drawings 

Open the Default model of 12345fsc.dgn in MicroStation Connect.  Attach the Existing Detail and Geometry drawing’s appropriate 
models as reference attachments.  OpenRoads Designer detail features are generally found in the Default-3D model of the 
drawings.  Fit View. 

Bring up the NH_FSH Tasks by setting the Select V8i mode to Dialog.  Use the first task - Front Sheet Cells - to open the cell 
selector N:\CADD\CADD\Connect-Workspace\Workspaces\NHDOT\Standards\Cell\NH_FSH.csf file.  Cells can also be selected 
from the NH-CE-Borders.cel file directly. 

Rotate and Scale the border to fit the Detail 

Select the BDR-FS-C-S-W border from the Cell Selector.  This 
will bring up the place cell command with that cell active.  The 
default Annotation Scale should be 1”=50’.   Use the X-Scale 
and Active Angle settings in the Place Active Cell tool to 
manipulate the cell to encompass the detail. 

A large text label can be added outside the border indicating the 
rotation and scale used for reference.  Note that the detail’s 
scale will actually be the X Scale factor multiplied by the 
Annotation Scale, 1”=50’ in this example.  For the actual 
MicroStation scale multiply by 12.  In this case the scale factor 
of 4 x 50 is 1”=200’ x12 gives a MicroStation scale of 1:2400. 

Rotate the view along the bottom edge of the Border cell. 
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Place Named Boundary to Create the Sheet model 

Use Task - Place Named Boundary or go to the Ribbon and open the View Tab and select 
the Place Named Boundary tool.  Use By 2 Points, check the Create Drawing box, name it 
FRONT SHEET, place corners, and Accept. 

 

 

 

In the Create Drawing box - Set the Drawing Seed to Detail_2d_English_SheetOnly 
and set the Detail Scale to the value determined during the border’s placement. Click OK. 

 

When the sheet opens, open the reference files box and select the referenced Default 
model attachment.  Verify the scale, Change the Display Overrides to Never and unselect 
the Scale Line Style by Reference Scale. 

   

Re-open the Default model by using the magnifying glass 
link to the Design model or the models tab. 

 

 

Work in the Default model – the Front Sheet Detail  

Delete the border placed earlier.  The outline of the Named Boundary should remain indicating where the sheet was created in 
relation to the detail.  A closed Clip Boundary can be created around the detail if necessary.  In the reference file dialog box 
highlight the referenced Detail drawing(s), then select the Clip Reference tool, method Element, select the element and accept. 

Use Level Display to turn Levels on/off to match the Construction plan check list. 
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Other Drawings can be attached as needed.  These may include the ETXT drawing for road names and “To Town” labels, the PNT 
drawing for construction limits and the ERL\ERT drawings for property lines and boundaries.  In some cases, it may be easier to 
copy needed graphics from the referenced drawings into the Default model, use the Tasks to set attributes and then use Change 
Element Attributes or Change Text Attributes.  Or use the Tasks and create new notes for the construction limits and other text 
that are referenced.  Shut off the display of referenced files or levels when done.  Save Settings and Save.    

Work in the FRONT SHEET sheet model 

Open the sheet model.  The detail from the referenced Default model should appear as it was just defined and saved.  To finish 
the Front Sheet, add the following cells from the Cell Selector or the NH-CE-Borders.cel library using the Place Cell tool.  These 
cells should be at 1 scale with the origin placed in the bottom left corner of the sheet model. 

• BDR-FS-C-S-W 

• BDR-FS-LOCMAPGIS 

• BDR-FSC-FSTXT 

The BDR-DOTNTH north arrow cell can be placed using a negative rotation of the referenced detail’s Default model.  

Create and Attach the GIS Location Map 

Follow the procedure outlined in create-gis-locmap.pdf to create an 8½" x 11" location map PDF file.  That document references 
seed GIS file called TOWN_12345_LOC.mxd which can be copied into the project from N:\CADD\CADD\Connect-
Workspace\Workspaces\NHDOT\Standards\Data\. Directions for attaching the PDF as a raster reference are covered in attach-
locmap-pdf.pdf. 

Raster Reference the locmap pdf into the cell’s placement points. 

Clip the raster. Save Settings and Save the dgn. 

  

https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/create-gis-locmap.pdf?csf=1&web=1&e=9dWW1j
https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/attach-locmap-pdf.pdf?csf=1&web=1&e=7CImhW
https://nhgov.sharepoint.com/:b:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/attach-locmap-pdf.pdf?csf=1&web=1&e=7CImhW
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P-7-6: Station Offset Macro - Ohio 

Description:  

This application is used to place station and offset labels relative to a selected MicroStation curvilinear element.  It uses the active 
level and Text Style so they should be set appropriately before starting the macro. 

Opening the Application:  

The application is loaded in MicroStation Connect Edition or OpenRoads Designer 
Connect Edition by issuing the key-in: 

vba load OHDOT_PlanLabels.mvba;vba run OHDOT_PlanLabelsMain 

Application Operation:  

When the application is opened, a dialog like the example below is displayed.  

 Select Centerline Element  

Labels are placed relative to a selected MicroStation curvilinear element. This element 
can be an OpenRoads Designer alignment; however, the application does not read the 
OpenRoads data and cannot extract the beginning station value, or any station equation 
information, from the selected element.  

The selected element is highlighted with a scarlet arrow displaying the direction of the element.  

 Reverse Direction  

The direction of the selected element is revered by clicking this button. Note that this reverses the direction of the element in 
memory only and does not reverse the direction of the selected element.  
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Begin Station  

Key in the beginning station value for the selected element. 

Mode  

This option is used to select the placement mode for the label.  Two options are available: Perpendicular or Horizontal.  

Type  

This option is used to select the type of label to be placed. Four options are available: Partial Station, Full Station, Station and 
Offset, or User Text.  

Prefix 1  

This field is used to key-in a prefix for the first line of the label.  

Suffix 1  

This field is used to key-in a suffix for the first line of the label.  To use ± copy from here or use the place text command and select 
the symbol and copy if from the text editor box.  

Prefix 2  

This field is used to key-in a prefix for the second line of the label.  

Suffix 2  

This field is used to key-in a suffix for the second line of the label. To use ± copy from here or use the place text command and 
select the symbol and copy if from the text editor box. 

 

 Place Label  

Select this button to initiate the placement process. Labels are placed at the cursor location with computed station and offset 
values, depending on the Type of label to be placed.  
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P-7-7: Civil Labeling 

Area Labels 

Draw the area in a level that makes sense… Drain 1, Drain 2, … 

 

Open the Drawing workflow.  Select the Annotate Tab.  Select the Place Label 
tool, fill in the box as seen.  

  

Hit on the shape/element to annotate. Then place the text.  The text will be 
the shape’s level name followed by the area. 

If the text looks funny after placement, use Edit Text. Hit on it and then click 
away to accept.  Not sure why it happens.  If a leader is wanted use the first 
icon at the top left. 

If the shape’s level or area changes the text will update.  The text used is for 50 
scale.  It will react to changes in annotation scale. 

Station Offset Labels - ORD 

Set the level to contain the label as the active level.  Open the Drawing workflow.  
Select the Annotate Tab.  Select Place Label, fill in the box as seen.  

In the bottom left of your screen there will be a prompt to Identify Element.  Hit 
on the Alignment or feature that the station and offset will come from.  May want 
to tentative snap until the proper alignment is identified and then accept it.   

Next select the Point Location and then the location of the flag.  The Start At 
point can be changed from Terminator to Flag if desired. 
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Borings and Labels 

Features have been created for the various subsurface exploration types.  The Bureau of Materials and Research will typically 
provide a list of station and offsets for layout. 

 

 

 

Return to Index 
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P-7-8: Print Organizer - Not Sheet Index 

Return to Index 

 

Using Print Organizer 

Print Organizer is a batch print utility designed for printing and reprinting sets of files, models, and Project Explorer links.  A default 
.pset can be copied from N:\CADD\CADD\Connect_Seed_Project\Imperial - USSF\Cadd\CutSheets\00000POP.pset.  This file 
contains folders to put the sheets into so they are organized like the Sheet Index.  Delete unnecessary folders and populate the 
ones needed. 

 

1. From MicroStation Connect or OpenRoads Designer, Open Print Organizer     File > Print > Print Organizer.  Click on the 
Open button or File > Open and select the pset above that you copied into the project’s PlanPDFs folder.  

 

Screen capture of Print Organizer 
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2. It may be beneficial to select the printer icon and select your printer before adding sheets.  From the print box click on Printer 
Setup.  Select the NHDOT-PDF-BW-Layers-links.pltcfg file by clicking on the … and finding it in the list. OK then Cancel 
after selecting the printer. 

3. Select a folder and add files to be printed in Print Organizer using the Add Files Button, 
File > Add Files to Set.  Click ADD to open the Select Files Box, browse and add files. 
Multiple files can be added from the same folder using <CTRL> or <Shift>.  Click Done 
to add them to the Create Print Definitions box.  Click ADD again to add files from a 
different folder.  After files have been added, select a Print Style Definition.  Use 
BorderLevelandColor when adding OpenRoads Designer or MicroStation Connect plan 
dgns containing border cells.  Select OK and all models from the selected DGN files which 
contain a border are added to the Print Organizer window.  This may take some time if 
adding many models.  

4. Delete any models which were added that do not have Borders in them.  Usually these are Default models and can be 
identified from the Model, Print Area and Scale columns as the scale will be odd due to it not having a border.  Highlight 
and hit on the X to remove from the .pset. 

5. Files can be placed in any order desired by dragging them or selecting them and using the move up or down Icons on the 
tool bar.  Only one file can be moved at a time so if files were placed in the wrong folder it may be easier to remove them 
and then re-add into the correct folder. 

 

Screen Capture of Print Organizer with files 
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6. Previews can be generated by selecting all of the files and clicking File > Print Preview.  If multiple files were selected, you 
can use the arrows to view previous/view next.  It does take a little time for the preview to be generated. 

7. If not already named, Save the .pset using File > Save As, select the 
directory.  Typically, these files will be stored in the project’s 
\CADD\PlanPDFs\ folder.  When naming the file, be aware that the pset 
file name is used to generate the plot file names.  For final project pdf 
prints, the pset should contain all project sheets in order, be stored in a 
\POP subfolder and be named PRJNAME-12345POP.pset.  

8. To print the files, select the desired files or the top level folder in the left 
pane if printing all the sheets.  File > Print will bring up the Print Dialog 
box.  The print driver selection can be re-defined here.  When creating 
separate pdf's the Output File Names can be selected as well as the 
output directory. 

9. Output File Names use Named Expressions and can be defined in a 
variety of ways.  By default, it uses the format of  

<print counter> - <print set name> 

to name the files.  Other expressions can be selected and previewed 
here.  For the final PDF plan set, set the Expression name: to Custom 
and Specify Expression as: 

PrintSet.Name & System.String.Format ("{0:D4}", 
00+PrintDefinition.SetPrintDefNumber)  

Click the Preview Names button to confirm that the files will be named 
as expected.  Click OK when ready.  See Help > Contents > Named 
Expressions for documentation on creating your own expressions. 

10. Select (all) files and click OK to print the files.  

11. The Message Center should indicate all the prints generated.  It may be 
necessary to scroll down through the list to find any issues. 
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Automatic Sheet Numbering 

The use of Named Expressions has been expanded to include automatic sheet numbering.  The variables $PSETNO$ and 
$PSETTOT$ have been defined in the NHDOT-PEN.TBL and are used on updated border cells.  This allows the total number of 
sheets and the sheet number to be extracted from the pset file.  All project plan sheets must be included in the pset for the 
numbering system to be correct.  Additional tasks and filters have been created to place borders in drawings with the PSET 
variables displayed.  Additionally, you can edit the sheet number or total sheets text block to the variables to use them.  Previously 
used sheet number levels would need to be shut off if copying the PSETSHTNO cell onto old borders. 

Final PDF Prints  

To print a single PDF file with all sheets, change the Submit as: from Separate print job to Single print job.  A multipage PDF 
will be created with the same name as the saved PSET file.  Open the combined PDF and review all the sheets.  It is easier to 
look through this combined PDF instead of opening every individual PDF. 

The final plan prints should be individual PDF's named for the pset and sheet number as noted above.  These pdf files can be 
stored in a \POP folder under the CADD\PlanPDFs\ directory.  A 12345ROW.pset can be created for PDF ROW plans in the same 
manner. 

Print styles 

The print style is set in the Create Print Definitions box after using Add and selecting files to be printed but before hitting OK.  Click 
on the magnifying glass and set the desired Print Style, hit OK and then OK again to create the print definitions using the selected 
style.    The print style can be changed later by selecting files in the Print Organizer view pane and then selecting Tools > Apply 
Print Style. 

Commonly used Print Styles: 

• BorderLevelandColor - used for cut sheet dgn's with multiple models with the border in them 

• BlktoWhte - Used for Cutsheet models containing aerials - defines pen table nhdot-pen_white2.tbl and sets Rasterized 
setting 

• PDF – will not rotate print area of portrait xsections  
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Print Styles - Manual Settings Print organizer - Fence - define from shape settings 

When adding drawings to be printed, select the Manually Specified Options button to define your own print definition attributes.  
The BorderLevelandColor print style settings are shown to the right, with the addition of the Main tab being set to View 1.  These 
are all settings that will need to be specified by the user when Manually specifying settings.  Other common settings to adjust may 
be the pen table, settings for user defined borders, rotation of the Fence alignment to X or Y direction, paper size, or the Display 
list. 

 

A print style could also be created through Tools > Define Print Style saved and then applied to a pset rather than manually 
changing settings.  The advantage is that it could then be exported and used in other dgns. 

 

 

Other Documentation / Information 

After opening Print Organizer you can open saved .pset's and .job files using the File > Open option and selecting the .pset or .job 
set file.  (may need to toggle the Files of type box to see .job files)  By saving them all in the CADD\PlanPDFs\ directory of the 
project they will be easier to locate when needed. 

 

If when adding a file no sheets are added, open the file, open the models dialog box.  The borderlevelandcolor Print set definition 
works on cells (shapes) in the master file whose outside edge is color=84, lw=0, and ls=0. 

 

For a more comprehensive look at the Print Organizer utility select Help > Contents > Working with Complete Designs > Printing 
> Print Organizer 

 

Also on the Bentley Communities site MicroStation V8i Print Organizer - Getting Started Guide 


