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https://mm.nh.gov/files/uploads/dot/remote-docs/nhdot-ce-cadd-documentation-introduction.pdf
https://mm.nh.gov/files/uploads/dot/remote-docs/nhdot-ce-cadd-documentation-microstation.pdf
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OpenRoads Design — Contours
P-6-7. Contour Creation (CTR and PCN) for plans from Terrain

Return to Index

Introduction Whole - Video — P-6-7 CTR Creation

Contours can be extracted from a Scalable Terrain Model (STM) or a Terrain Model (TM). A STM can also be used to create
HEC-RAS sections. The STM can be created from several different sources including files, points, breaklines or ORD Terrain
Models. These combined STM can be exported to a TM, Contours Extracted or saved for future use.

https://communities.bentley.com/products/3d imaging and point cloud software/w/wiki/10678/extract-contours
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-microstation-contour-

from-terrain.mp4?csf=1&web=1&e=Abbz6d

4“4 Elements (1)

Annotation scale issues with Major contour text means if you want them to look correct 4 By Terain Model Point Cloud?
you need to save them as separate models based on the scale you want to show them. b & Calculated Features
The gaps for the text are not scalable with annotation scale as changes to the text is. > R Source Features

& From Point Cloud

Boundary for Clipping Terrain or Contours Video — Create STM.dgn
and Boundary

Calculated Features Display

A boundary needs to be created from the terrain model to clip the contours. When Major Contours o
generated they become unclipped. e o
5 Off
Create\Open 12345-E-STM.dgn (existing) or 12345-P-STM.dgn (proposed) in the \PRJ Ers%w_w:s on
directory using the 3D Design seed file. High Pon of
Attach the E-Terrain model's Default-3D model. Make sure the view is set to Top Source Features Display
. . . . . . .. Ereaklines Off
rotation and Fit View so the entire terrain is visible. Boundary on
Imported Contours Off
Select the terrain model. In Element Properties, change the display to only show the skonds o
terrain’s boundary by having all feature display settings to Off except the Boundary Veids O
. . Feature Spots Off
setting. It may be necessary to set the Override Symbology property to Yes. —
Terrain\NH_Existing_Boundary
Override Symbology Yes
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https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-p-6-7-ctr-creation.mp4?csf=1&web=1&e=1WY4OF
https://communities.bentley.com/products/3d_imaging_and_point_cloud_software/w/wiki/10678/extract-contours
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-microstation-contour-from-terrain.mp4?csf=1&web=1
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-microstation-contour-from-terrain.mp4?csf=1&web=1
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-p-6-7-1-create-stm-dgn-and-boundary.mp4?csf=1&web=1&e=aT9aTe
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-p-6-7-1-create-stm-dgn-and-boundary.mp4?csf=1&web=1&e=aT9aTe
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Set the level to BDR-Clip-Boundary. Make sure color, linestyle and weight are set to ByLevel.

Level Display — Shut off all levels except BDR-Clip-Boundary.

Select the Create Region tool. Set the method to Flood (left 0 O G N~ | ame
i i F F YA D 2 imy
button in top row) and Fill Type to Opaque. O gL, W
Move Copy Rotate | = —

Click inside the terrain boundary and Accept the selection. i Ly 7 & Create Region

Turn on all levels

The closed shape can be selected and the fill turned off leaving only the Shapes out line on.

Create a Scalable Terrain Model including an ORD Terrain Model Video —

Create STM and Coutours

Continuing in the 12345-E(P)-STM.dgn the drawing should be opened into its Default-3D model.

% Create Region - *
Alsfals
F|II e | Opaque hd
Fill Color (2 81 -

Maximum Gap: | 0.0010

Keep Original
[] Associative Region Boundary

L

Text Margin: | 0.0000

Attach the terrain dgn’s

Default-3D model. Switch the workflow to Reality Modeling > Attach tab and select the Scalable Terrain Model tool in the
bottom right of the Scalable Terrain Model pane.

4% Scalable Terrain Model (0 of 0 listed)

File | Edit View Display Utilities

3 New. RNRLLLLEBY [J

r}:] 2_1:'!:3'2: Description 8 ./ K &
& Detach

%3 Export STMto TM

1]2]3]4]s|6]7]s| © .7k L4

Select File > New...

and name the STM with the name. 12345-E(P)-STM.stm
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https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-p-6-7-2-create-stm-and-contours.mp4?csf=1&web=1&e=ey5rgc
https://nhgov.sharepoint.com/:v:/r/sites/DOT-ProjectCentral-Home/CADD%20Document%20Library/nh-ord-p-6-7-2-create-stm-and-contours.mp4?csf=1&web=1&e=ey5rgc
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The New STM Settings box will be displayed. Set the Level, add a Description,
contours-on, triangles-off and set the geographic coordinate system. Click OK.
This will create the STM.

Next the Terrain model needs to be attached as an elevations source in the
STM. Use File > Modify to Open the STM Elevation Source Editor. In the
Editor use File > Add Terrain Model > DGN Level... Select the terrain model
reference and the E-Terrain level then click Select. The Terrain will be added
to the STM but not visible. This allows you to add additional terrains or other
features to the STM if needed.

Use Edit > Generate or click the Generate icon to display the generated STM.
Close the STM Elevation Source Editor.

&4 STM Elevation Source Editor (12345-E-STM2.stm - Empty) = X
File | Edit
| AddTerainModel  » | Files...
r Add Points 4 DGN Level...
s i i
Add Breakline . Horizont... Vertical ... GeoCS Status
Add Clip »
Add Mask 4
Exit
< >

& Mew STM Settings - O X
General L
Level E-Temain
Color =] Bylevel
Line Style =] Bylevel
weight =] Bylevel
Class Primary
Scalable Terrain Model -~
Description Existing
Shaded View Density 100.0000
Mot Shaded View Density 50.0000
Views 1-2-34-56-7-8
Locate True
Calculated Features Display ~
Contours On
Triangles OFf
Draped Fasters OFf
Extended L
Snappable Snappable
Clip True
Geographic Information ~
v (Geocoding
I NHe3/2011F v
Description NSRS11{NAD83/2011) New Hamp:
Carcl
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Create the Contours and Update the Symbology

Use Element Selector to select the STM. In the Properties box expand the Scalable Terrain
Model’s Calculated Features and select Contours. Change the contour interval as desired and
set the precision to 0. For existing contours set the smoothing to Vertex - Smoothing factor
10 , for proposed set it to none. To remove the * symbol from the contours use File > Settings
> File > Working Units. Click Custom to delete the Labels and save settings.

Expand the Contours dropdown and set the properties of the Major and Minor Contours as
shown below. (P- for proposed) Use ByLevel settings and set Text Interval as needed. SET
the Annotation Scale!

Properties

4 5 Elements (1) = >
) 4 %y Elements (1)
4 & Scalable Terrain Model
4 Ly Scalable Terrain Model
4 Iz Calculated Features
4 X2 Calculated Features
4% Draped Rasters 2
4% Draped Rasters
Triangl
D rangies B2 Triangles
e —| .
7~ Contours 4 =i Contours
vE Major Contours +| = Major Contours
| H Minor Contours . v S) Minor Contours

General » General ~
Display On Display On
Level miin—Cori our-Major Level E-Termain-Contour-Minor
Color E=l Bylevel (13) Color E= Bylevel (13)

Line Style == Bylevel (0) Line Style E= Bylevel (3)
\nleight =] Bylevel (2) \Weight = Bylevel (1)
Transparency 0 Transparency 0

TextStyle -~ TextStyle ~
Text Style NH_CTR_E_008_Eng Vert Mo_Ch Text Style (None)

Contour Labels ~ Contour Labels -
Text Level E-Terrain-Contour-Major T‘.Ext Level E-Termain-Contour-Minor
Display Text Yes Display Text No
Text Interval 200.0000 Text Interval 500.0000

Depression e Depression -
Depression Color E=] Bylevel (13) Depression Color = Bylevel (13)

: : B Depression Line Style = Bylevel (3)
Depression Line Style == Bylevel (0) . - —

) ) — Depression Weight = Bylevel (1)
Depression Weight E=1 Bylevel (2)

4 ¢ Elements (1)
4 Iy Scalable Terrain Model

4 L Calculated Features

4% Draped Rasters
5] Triangles
el |Ej Contours
| = Major Contours
« = Minor Contours

Contours
Max Slope Option None
Max Slope Value 1.0000

Contour Label Precision 0

Smoothing factor L

Smoathing Spline
Major Interval 5.0000
Minor Interval 1.0000
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Fit view to ensure the whole terrain is displayed and In the Scalable Terrain Model box, select Edit > Extract Contours. The
Extract Contour tool will display. Use the Area drop down to select mode View. Uncheck the Group in a cell box. Select the
view to extract the contours.

NOTE: There seems to be an issue that no contours are generated if the Element option is used, so the clipping will need to be
done when copying the contours into the ctr or pcn file. If generating clipped contours does work using an Element, do that and
just copy the contours below with no fence.

4% Extract Contours — x

Area:) | View v
Use Fence
Use All STM

[] Groupin a cell

Open the ctr.dgn in a Separate Session Video - Copy Contours to CTR.dgn

This file should have only a Default-3D model to start. Reference attach the STM.dgn’s Default-3D model. Create a Fence from
Element and select the Boundary created. Copy Fence Contents using the Clip option to copy the contours into the ctr dgn.
Text justification of the labels may need to be changed. Use element selector and select all text in the drawing then use the
Change Text attributes tool to change the justification only to Right Top or change the justification in the Properties box.

In the Models box Copy the Default-3D model and name it appropriately for the contours it contains, this will open that model.
Detach the STM reference file and delete the Clip boundary. Reopen the Default-3D model and delete the contours. Save.

Open STM file and update for different Scale and or Different Intervals Video — Create Others
Delete only the contours leaving the clip boundary and the stm.

Change the Annotation scale to 1”=20’ or what is needed and Fit View.

If needed select the STM and update the major/minor increments.

From the STM toolbox select Edit > Extract Contours > View. and Accept.

Select all Text elements and change them to top right justification.

Save Settings and Save the DGN.
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Return to the CTR dgn update the model then copy for next iteration — Repeat
In the ctr dgn open the Default-3D model. Delete any contours.

Open the reference file dialog box and reload the STM reference file to show the latest contours.
Change the Annotation scale to match the new contour’s setting 17’=20’ and fit View.

Create a Fence from Element and select the Boundary created.

Copy Fence Contents Clip inside to copy the contours into the ctr dgn

If needed Select all Text elements and change them to top right justification.

Save Settings and Save the DGN.

Different models to create, ctr-50 1 foot minor, ctr-20 1 foot minor, ctr-50 2 foot minor, ctr-20 2 foot minor

FINISHING

When done creating the different models in the ctr dgn open the Default-3D model and fit view. Shut off the display of the STM
and Delete every thing from the model. Use the Place Text command to place a large note “SELECT THE CORRECT MODEL
TO DISPLAY THE CONTOURS?” in the center of the view. Select the text and scale it up 50 times its size. This text will be seen
when the file is attached as a reference letting users know that they need to open the reference file dialog box and select the

appropriate model to display for the scale and needs of the plans it is being referenced into.

Save Settings, Save and close the ctr dgn

In the STM dgn Use the Scalable Terrain tool and save the STM file. Can delete the latest set of contours created.

Save Settings, Save and close the STM dgn
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